Jump to content

ADC 13 receiverconf.cr error authentication(mac) error discoverdocument(win)


Oliver Buch

Recommended Posts

Hi all,

 

I do have an issue on connecting through ADC Gateway. Internally works fine with workspace app an receiverconf.cr.

 

First symptom, logon with HTML5 works. Using connecting by typing the serveraddress at first connect with workspace app works but not a second time. If you log off and log on I'll get an authentication error (Workspace App for Mac ) and error discoverdocument with the windows app. In this case no credentials will be prompted. If you delete the account and type the netscaler(ADC) address it will work until you logoff. In this Case I have to delete the account from Workspace app and restart with the address of ADC.

 

In the private network it works as expected without any issues.

 

In public network connecting with browser and redirect to workspace app will work as well. Using the activation  function -> same Error as described. Executing the receiverconfig.cr won't work and prompt the same error.

 

here is a short cut of IPs:

ADC 13.0.52.24

SNIP 10.0.1.10/24

Subnet 10.0.1.11/24

ADC 10.0.1.12/24 (public Certificate bound to vserver)

 

Vserver with 2 policies web and client correct Storefront address Clientless Access to yes.

LDAPS policy (verification okay) Basic Authentication.

SSL policy-> tried to handle a couple different settings

STA is connected

Certificate Binding with link to intermediate and Root

Root Certificate is bound

 

 

 

1912.0 and as well CU1 same result

Storefront 10.0.2.1/24 (public certificate)

 

1912.0 and as well CU1 same result

DDC 10.0.3.1/24 (without cert and with local cert - same Issue)

 

Workspace 1912 LTS and 2006 same issue.

 

Citrix support had a check on it as well, and they don't know what the issue is and it will be tracked further.

 

Within the Firewall I tried with any policies (open door)

the storefront, domaincontroller and ddc is reachable from netscaler by ip and DNS, no proxy in between, stoped any antivirus, no thread protection...

 

The point is that there is no login screen when relogon or trying the activation through receiverconf file. 

Internal bacon is just internal, and not reachable from public. Reverse DNS is checked as well.

 

Does anyone do have any ideas?

 

Best Oliver

 

 

 

 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...