Jump to content
Welcome to our new Citrix community!

netscaler native otp config - manage OTP page Redirects to logonpoint/tmindex.html - Login schema Directory (directory does not exist error)


Recommended Posts

following this guide from Stan Demburg

https://www.irangers.com/netscaler-native-otp-limit-enrollment-one-device/

 

1) issue is that when i browse to gateway URL https://gateway/manageotp. it redirects to another Url, namely https://gateway/logon/LoginPoint/tmindex.html

however i am still able to login with LDAP fine.

 

to troubleshoot this, i managed to goto login schema, (security>aaa>login schema), and when i click on the pencil icon to check/edit any of the existing schema or create a new schema profile (and click on pencil icon under authentication schema) on the netscaler it says Directory does not exist

(Screenshot attached). could manageotp page issue be because of this ?

current version is build-13.0-58.30_nc_64 and tried to downgrade version to build-12.1-57.18_nc_6412.1-57 is still the same.

 

 

2) second issue is that, when i want users from internet to be able to register for OTP devices hence i removed the client source IP part from the expression. would that meet the requirement ? 

 

HTTP.REQ.USER.IS_MEMBER_OF("DMZ_OTP") && HTTP.REQ.USER.ATTRIBUTE(7).CONTAINS("#@")

 

attached is the screesnhots of the policies for the same,

policy1.png

policy2.png

policy3.png

policy4.png

policy5.png

loginschemaerro1.jpg

loginschemaerro2.jpg

Link to comment
Share on other sites

  • 3 weeks later...

Hi Kedar

 

I also got the problem editing schema's ADC says Directory Does Not exist, and unable to select any of the schema's in the folder.

I can see all the schema's in the GUI, but selecting them does not enable the Select button, I cannot see the schema content either.

 

Did you find any solution for this.

 

I'm running NS13.0 47.24.nc

 

Best Regards

Stian

Link to comment
Share on other sites

  • 2 months later...

Seems that ADC is missing "/var/netscaler/logon/LogonPoint/custom" folder and all it's contains files in disk.

 

Solution:

Step-1: You may rebuild a same version VPX in lab or find a same version ADC appliance.

Step-2: Download whole "custom" folder and contains files to local and upload to defective ADC appliance. 

 

Note:

 

Aplliance no need to reboot, just refresh your browser and check Schema should working now.

For ADC HA deployment, better to make sure both appliance NOT missing the folder and files.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...