Jump to content
Welcome to our new Citrix community!
  • 0

MCS Catalog Update Fails - Azure CVAD 1903


Simon Magee1709159107

Question

Hi,

 

I have a small MCS catalog deployed in Azure, using managed disks. Deployment of 3 VM's was successful and they all boot fine and I can logon/launch applications. The issue I have is when I come to update the MCS catalog, I get errors not long after the process starts. I have tried removing any reference to any 'preparati-xxxx-xxxx' within the resource group.

 

Background - The original VM was hosted on XenServer and converted over to Hyper-V before being deployed into Azure. All XenServer drivers were removed and VM booted ok without issues in Hyper-V first. The vDisk was then uploaded to Azure and a Image VM was created from the disk - VM deployed then used managed disk in Azure for ~MCS catalog deployment,  The 3 CVAD servers all boot ok and you can logon and launch applications, it's the update process I am having some issues with,

Studio Error.PNG

Link to comment

2 answers to this question

Recommended Posts

  • 0

Just posted below in another thread. Seems to be the same issue. - https://discussions.citrix.com/topic/409495-citrix-cloud-mcs-error-when-attempting-to-update-vdi/#comment-2067641

 

Hi!

I have noticed this issue some times now... Although not running CMD, but CVAD-Service on Azure

 

Do you have a preparati VM/Disk/NIC In the Azure ResoureGroup which the Machine Catalog has its machines in? If so, it might be "stuck", I've solved this by manually deleted the resources from the Resource Group and also from the storage account (Citrix Cloud deployment uses Storage account to keep track of machines and deployments).
1. DELETE - Look for the Preparati-xxx in Resource Group and delete that.
2. DELETE - MachineConfig" table: Delete the row related to Preparati-xxx (You can match the name from MachineConfig value)
3. DELETE - "MachineState" table: Delete the row related to Preparati-xxx
4. EDIT - "StorageAccount" table: edit MACHINECOUNT: 41 -> 40 

 

Let me know if this was your solution!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...