Jump to content
Welcome to our new Citrix community!
  • 1

XenServer 8.1 Citrix hypervisor windows management agent high memory usage


Eduard Meiler

Question

Hello to all,

 

we are runung Windows Server 2016 and 2012R2 on XenServer 8.1. for some month now.

Some weeks ago we did the latest XenServer Updates and we are facing now a problem with citrix hypervisor windows management agent.

The Agent takes the whole free memory at the vm. XenServer Center shows that the agent is not runnung.

The Vm is not acceable through the RDP.  The only solutions is only to shutdwon ad restart the VM through XenCenter.

This happens mostly on Exchange Servers every 4 days.  Last days also a Domain Controller and a File Server was effected. 

 

Any help will be appreciate.

 

Regards

 

Eduard

 

 

Link to comment

21 answers to this question

Recommended Posts

  • 0

Hi Alan,

thank you for your answer.
 

Here is the info:
 

Citrix Hypervisor PV Tools  - 9.0.33

Citrix Hypervisor Windows Management Agent - 7.2.1555

 

On host:

 

Type "xsconsole" for access to the management console.
[root@xen14 ~]# xenstore-ls -f | grep driver
/local/domain/1/drivers = ""
/local/domain/3/drivers = ""
/local/domain/8/drivers = ""
/local/domain/8/drivers/0 = "Citrix XENBUS 8.2.1 "
/local/domain/8/drivers/1 = "Citrix XENVBD 8.2.1 "
/local/domain/8/drivers/2 = "Citrix XENVIF 8.2.1 "
/local/domain/8/drivers/3 = "Citrix XENIFACE 8.2.1 "
/local/domain/8/drivers/4 = "Citrix XENNET 8.2.1 "
/local/domain/9/drivers = ""
/local/domain/9/drivers/0 = "Citrix XENBUS 8.1.1 "
/local/domain/9/drivers/1 = "Citrix XENVBD 8.1.0 "
/local/domain/9/drivers/2 = "Citrix XENVIF 8.1.0 "
/local/domain/9/drivers/3 = "Citrix XENIFACE 8.1.0 "
/local/domain/9/drivers/4 = "Citrix XENNET 8.1.0 "



Regards
Eduard Meiler

Link to comment
  • 0

I did the same. Uninstalled PV Tools and the Agent. Restarted and installed the VM tools.
On one of the 3 VM's I tried one more thing. In the windows Update the update for Citrix Updates was displayed. I tried this.

After all the VM crashed every time while booting. So I went back to the last snapshot.

Do you have the same experience?

 

Link to comment
  • 0

Just to let you know the couple of VM's I had with high CPU I found that if I went to device manager and did show hidden devices

and removed all hidden devices (not just nics but everything). On next restart I get prompted about new drivers installed and a 

dialog box asking for a second restart. Once the second restart occurs high cpu no longer happens.

 

--Alan--

 

Link to comment
  • 0

I have the exact same problem here. We have Xenservers on 8.1, 8.0 and still 7.4. All presenting the same issue all across a range of guest VMs. We also have VMs running the tools on 8... and 9... versions of XenTools, just happens to all of them.

 

After restarting the service "Citrix XenServer Windows Management Agent" for 2 or 3 times seems to free the memory again, but it keeps coming back and it's kinda unpractical.

 

 

Citrix Xenguestagent High Memory Usage.png

Link to comment
  • 0

Hi,

 

we have the same issue. Xenserver 8.1 with patch XS81E006. Xen guest tools consumes all memory (Windows Server 2019). RDP not possible, reboot through XenCenter is only solution.

 

I have uninstalled citrix tools and installed it again. But i still have 5 services:

 

citrix hypervisor pc driver installer

citrix hypervisor windows and management agent

citrix installation and update agent

xenserver agent

xenserver pv driver monitor

 

Checked also hidden devices - i could only find mouse, keyboard and shadow volumes... nothing else to uninstall

 

-- Norbert --

Link to comment
  • 0

Hi,

The Citrix drivers behave differently with the different VMs. Some VM's had problems after 4 days . The longest time was 18 days afte the VM run out of memory.

 

Yesterday we did this on all our VM's:

 

- Uninstalled CitriX Managment Agent

- reboot 
- Uninstalled Citrix Hypervisor PV Tools

- reboot

- Connect through RDP to the VM and copied and Installed the newest driver managementagentx64  9.033 from Citrix Site 
( we did not installed the drivers at the VM with the right click at the Citrix XenServer ) 

- After installation VM reboots
- After reboot I logged in and got the info to reboot a second time 
- After the second reboot some VM lost their IP settings so I had to edit them again

- At the programms section only  Citrix Hypervisor PV Tools is shown. Citrix Managment Agent is not displayed anymore

 

Lets wait 20 days and see if that help

Regards
Eduard

Link to comment
  • 0

Hi,

 

we are having the same Problem. XenServer 7.1 CU2 on latest Patch-Level. Since the latest Hypervisor Tools were installed the Memory Usage of the Management Agent on our Server 2016-Systems  is growing day by day till the machine is not responding anymore. Reboot fixes the Problem for some days. Is there any solution for the Problem?

What will i loose when i disable Windows Management Agent as Workaround?

 

Regards

Ingo

Link to comment
  • 0
1 hour ago, Eduard Meiler said:

 

Hi Eduard,

 

not exactly.

- I uninstalled the "Citrix XenServer Windows Management Agent"

- Reboot

- I did a Repair-Install of "Citrix Hypervisor PV Tools"

- Reboot twice

 

The memory usage of "xenguestagent.exe" is continually growing. (more than 1 GB RAM in one week). On our Provisioning Servers which has 64 GB of RAM the highest usage for xenguestagent.exe i have seen was about 25 GB!  In this situation last Reboot was about 4 to 5 weeks ago.

 

By the way i can also see this behaviour on a freshly installed Server with managementagentx64  9.033 from Citrix Site. (No other version of Tools installed before)

 

As workaround i will try disabling the Service "Citrix Hypervisor Windows Management Agent". I don't need Monitoring in XenCenter or the "Performance Tab".

 

Regards

Ingo

 

Link to comment
  • 0

Hi all,

 

after some weeks after stopping and disabling the service "Citrix XenServer Windows Management Agent" we don't have any memory spikes problems.

 

As i have stated before, we only lost the Monitoring data not being gerenated on the Performance Tab on XenCenter. As we have an external tool to accomplish this task we can use this workaround.

 

As Ingo stated, we also tested different versions of the Management Tools(8xx-9xx), different versions of Windows VMs(2008r2-2019) and even different versions of Xenserver(from 7.4, 8.0, 8.1). All of them have the same issue after some time. I'm no expert in this field, but it seems to me that some Windows Update may have create a conflict with the Citrix drivers. Because the only thing that still is not being controlled in our env is the Windows Update and the Servers keep installing it.

 

I hope Citrix can find what's happening and fix it if needed. For now...I will just keep tracking the issue.

 

 

Best Regards from Germany,

Alex

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...