Jump to content
Welcome to our new Citrix community!
  • 0

Workspace App MFA Confirm Certificate



We have recently implemented Azure MFA with Citrix Netscaler, most is fine however connecting with Receiver/Workspace App the users get a confirm certificate message. 

Tried it with the older Receiver and the latest Workspace App, still pops up. Connecting via the Web works fine with no certificate errors. 

No issues with other applications that authenticate to Azure MFA. Just through the Workspace App.


If you click OK it works fine, we just don't want it popping up for users.


Any ideas?


Link to comment

1 answer to this question

Recommended Posts

  • 0

On your Citrix Gateway vServer under the SSL settings, or SSL Profile if you're using that, do you have Client Authentication enabled? Also, do you have a CA bound under Certificates on that vServer?


I can produce a similar experience where I get no Cert prompt from a browser but do using Workspace app.


To fix, disable Client Authentication if it's not needed.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...