Jump to content
Welcome to our new Citrix community!
  • 0

MTU Setting für PVS on Citrix Hypervisor?


Question

Hi, I got a little confused with the MTU settings for the PVS server. We use the Citrix Hypervisor 8.1 as hypervisor, where the MTU is set to 1500 on the network cards for the streaming network. The MTU value on the PVS servers is set to 1506. The MTU value which I have determined by ping on the hypervisor host is 1472(+28(?)) = 1500. Which value should I now set to 1500 or 1506 on the PVS servers? Which MTU should the switches use then?


Thanks a lot
With kind regards
Thomas

Link to comment

3 answers to this question

Recommended Posts

  • 0

Hi Thomas, short answer is that you do not need to make any changes, everything is fine.
 

There is a blog post which explain here - https://www.citrix.com/blogs/2011/10/02/pvs-5-6-the-mtu-story/

Pvs 5.6/6.0/6.1 MTU setting: payload size + UDP header (L4) + IP header (L3) + Ethernet header (L2) (default GUI Value: 1464 + 8 + 20 + 14 = 1506)
From an MTU perspective, Ethernet header, 14 is not counted in the maxium MTU of 1500.

 

Thats why with wireshark captures, packets with slightly greater length than MTU should be observed.
From PVS perspective, once you see UDP packets between server and target at 1506 (so no fragmentation) everything is fine.
 

Link to comment
  • 0

Later versions of PVS above version 6.1 include the header in their MTU setting so the setting of 1506 is actually correct.

 

If possible you could look at Jumbo frames (9k). For this to work the whole chain needs to "support" Jumbo frames (Network, Hypervisor,  OS and the "PVS stream application)

 

kind regards

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...