Jump to content
Welcome to our new Citrix community!
  • 0

Android Enterprise - Disable copy & paste from Secure Mail to non managed\non work profile apps


Stephen Faulkner

Question

After enrolling an Android 10 device into Android Enterprise with work profile I find that I am able to copy + paste data from the work profile app (in this case Secure Mail) to non work profile apps.  Does anyone know how to disable this?  Within the Android Enterprise per app settings there is no longer a disable copy + paste option as this was previously associated with MDX policies.

 

I have tried creating a Restrictions Policy and setting restrictions in the Android Enterprise section and the only setting which seems to relate to this is the 'Allow cross profile copy and paste' which I have made sure is set to 'OFF'.  The policy is definitely deployed to my test device but I am still able to copy + paste to non work profile apps.

 

Does anyone have any ideas if my approach is correct?  Is there another method to do this?

 

Running XM 10.12 RP2 On-Prem.

 

Thanks in advance.

 

Steve.

Link to comment

3 answers to this question

Recommended Posts

  • 0

Hi Steve,

  The only flag that controls this is the "Allow cross profile copy and paste" which should be OFF.    Please make sure that the device refreshes its policies. You can go into SH, preference, device info, refresh policy, then try again.  

If you still can copy paste into personal, then open a support ticket, and we would have to look into it.  I just tried on our cloud service and its working for me.

Thanks,

Alex

Link to comment
  • 0
1 hour ago, Alex Rubio said:

  The only flag that controls this is the "Allow cross profile copy and paste" which should be OFF.    Please make sure that the device refreshes its policies. You can go into SH, preference, device info, refresh policy, then try again.  

If you still can copy paste into personal, then open a support ticket, and we would have to look into it.  I just tried on our cloud service and its working for me.

 

 

Thanks Rubio,

 

Just tested this again after performing numerous refreshes, Secure Mail app delete and re-add, close SH down, restart device and re-open SH and Secure Mail and still no restriction.

 

I will raise a ticket in the morning.  Thanks for your help.

 

Steve.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...