Jump to content
Welcome to our new Citrix community!
  • 1

Director RDS License error

Carsten Peukert


I have installed Xa_1912_cu1 in a  windows server 2019 environment (full fixed). This is a complete new installation of citrix components.

Dedicated server for delivery controller, database, VDA, Storefront,ms licensing and other infrastucture servers.


The ms license server is activated and has RDS-CALs. The license server works great for VDA XenApp sessions.  There are no errors.

The citrix director show always "license error" - "RDS licensing has exceeded its grace period" under machine details (see screenshots).


What can I do?

director - machine details.jpg

ms license server.JPG

Link to comment

6 answers to this question

Recommended Posts

  • 0

Thanks for the hint, it's work.


I have always configured and assigned a GPO with RDP License server and RDP License mode configured.

The Terminal Server runs ok with no MS license warning.

This values are present under Computer HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services, but this is not enough.


After explicite setting HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core\LicensingMode the license warning in director disappear.

  • Like 1
Link to comment
  • 0

We had quite the same experience, XA1912.1 running on DDCs Win2016 with mix of 2012/2016 workers and RDS License server Win2019 with Per User CALs.  The RDS License server was shown as "unknown" in the Citrix Director.


After changing the registry key from 5 to 4 (Per User) : HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core\LicensingMode it all started showing fine : "License Available".


Solid solution :)

Link to comment
  • 0

I have the same issue since upgrading Infratructure and VDA's to 1912 LTSR.  After scheduled reboot this RDS terminal services error occurs.   Where is everyone seeing the RDS error in Director?


I am looking to do the following, whihc I have done on one SILO and it has fixed the issue.    


HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services --- Set RDS Server name and per user licence to 4 per user.  


HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core\LicensingMode -- -- Set RDS Server name and per user licence to 4 per user.  


I was told by someone to delete the following reg key "timebomb"  You have to take ownership of the key.  


HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Grace Period\L$RTMTIMBOMB 






Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...