Jump to content
Welcome to our new Citrix community!
  • 0

USB-NIC link status is changed to disconnected after a while



I have installed one USB-NIC into XenServer 7.1LTSRCU2, and I added to an udev configure file to fix the device name of USB-NIC to eth4.

# cat /etc/udev/rules.d/71-persistent-net.rules
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="60:84:bd:48:97:35", ATTR{type}=="1", KERNEL=="eth*", NAME="eth4"


After a while after starting, the link status of eth4 is changed from connected  to disconnected. The dmesg showed this. 

[26574.993606] usb 4-1: USB disconnect, device number 2
[26574.993861] ax88179_178a 4-1:1.0 eth4: unregister 'ax88179_178a' usb-0000:00:14.0-1, ASIX AX88179 USB 3.0 Gigabit Ethernet
[26574.993886] ax88179_178a 4-1:1.0 eth4: Failed to read reg index 0x0002: -19
[26574.993891] ax88179_178a 4-1:1.0 eth4: Failed to write reg index 0x0002: -19
[26574.994351] device eth4 left promiscuous mode
[26575.025621] ax88179_178a 4-1:1.0 eth4 (unregistered): Failed to write reg index 0x0002: -19
[26575.025624] ax88179_178a 4-1:1.0 eth4 (unregistered): Failed to write reg index 0x0001: -19
[26575.025626] ax88179_178a 4-1:1.0 eth4 (unregistered): Failed to write reg index 0x0002: -19
[26575.265813] usb 4-1: new SuperSpeed USB device number 3 using xhci_hcd
[26575.606960] ax88179_178a 4-1:1.0 eth4: register 'ax88179_178a' at usb-0000:00:14.0-1, ASIX AX88179 USB 3.0 Gigabit Ethernet, 60:84:bd:48:97:35

The eth4 network can be recovered by ip command, but the same automatically link down repeats.


I have done the following additional settings to change XenServer to high performance mode and disable USB auto suspend.

1. High performance mode

/opt/xensource/libexec/xen-cmdline --set-xen cpufreq=xen:performance
/opt/xensource/libexec/xen-cmdline --set-xen max_cstate=0

2. Disable USB auto suspend

echo '-1' >/sys/module/usbcore/parameters/autosuspend
modprobe usbcore autosuspend=-1

3. Modify grub.cfg for persistence

serial --unit=0 --speed=115200
terminal_input serial console
terminal_output serial console
set default=0
set timeout=5
menuentry 'XenServer' {
        search --label --set root root-vthidz
        multiboot2 /boot/xen.gz dom0_mem=4096M,max:4096M watchdog ucode=scan dom0_max_vcpus=1-16 crashkernel=128M@256M console=vga vga=mode-0x0311 cpufreq=xen:performance max_cstate=0
        module2 /boot/vmlinuz-4.4-xen root=LABEL=root-vthidz ro nolvm hpet=disable xencons=hvc console=hvc0 console=tty0 quiet vga=785 splash plymouth.ignore-serial-consoles usbcore.autosuspend=-1
        module2 /boot/initrd-4.4-xen.img


I did these things, but it doesn't solve, just because the time to become disconnected is extended. Are there any other required settings?

Link to comment

3 answers to this question

Recommended Posts

  • 0

The disconnection occurred after continuously transferring 2-3GB of data. When I tried to reproduce it on another host with the same configuration, there was no problem, so I was able to determine about a hardware issue.

However, the mysterious thing is that even if this USB-NIC is used on other OS(Windows 10, CentOS7, 8), it will not be disconnected! I will use this USB-NIC for a PC.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...