Jump to content
Welcome to our new Citrix community!

Storefront Upgrade 7.15 LTSR (3.12.0.17) to 1912 CU1 LTSR failed


Recommended Posts

Hey guys,

we run into troubles by making an upgrade like descriped in the titel.

 

We splitted storefront and delivery controller to two dedicated virtual machines.

 

First we upgraded the delivery controller. No issues.

Than we tried to upgrade the storefront server on the other virtual machine and failed.

 

There are two different behaviours which I believe could correlate.

 

The first one is that running the upgrade an error occure where the system tells me that something is actually in use of this path:

"C:\inetpub\wwwroot\Citrix\StoreWeb\receiver\images\common"

 

When we stop all citrix services and the www-publishingservice, the setup is able to run but he still finish it with "failed", too.

 

Sadly I have no logfiles yet because we reenabled the snapshot we created before and I missed to save the textfiles on another machine. I will remember when the next try fails too.

For my untrained eye there wasnt a clearly note about the problem. Just very much entries about failed installations. ^^

 

Do you maybe have some suggestions what I can try else? Maybe someone had some similar issues.

 

On the following topic the most things we tried are listed by member "fraport.spies":

"https://discussions.citrix.com/topic/407281-update-ltsr1912-software-components-failing/"

 

Copied the suggestions below and added some notes in red:

 

[...]

Delete any thumbs.db files inside C:\inetpub\wwwroot\Citrix\   (there were none) (No thumbs.db files there for us)

Confirm that servers being upgraded are removed from any load balancer and have no active user sessions connected. (No load balancer)

Stop the following services: CitrixConfigurationReplication; CitrixCredentialWallet; CitrixDefaultDomainService; CitrixPeerResolutionService; CitrixSubscriptionsStore (We did)

 

[...]

Clear files in C:\inetpub\wwwroot\Citrix\<all folders>\App_Data\CtxsWebProxyIconCache\ (We didnt tried + only StoreWeb has the folder CtxsWebProxyIconCache)

Rename C:\ProgramData\Citrix\Storefront Install\   (optional: delete) (Didnt tried)

Check C:\Program Files\Citrix\Receiver StoreFront\Services\ProtocolTransitionService\Citrix.DeliveryServices.ProtocolTransition.ServiceHost.exe.config  regarding the version - does it match the currently installed Storefront? It didn't for us, as it was 3.11 instead of 3.12 - we backuped the file and changed all values reading 3.11 to 3.12. I'm sure this was the main step in helping us upgrading Storefront successfully! (We have no subfolder called "ProtocolTransitionService". A service with a name like this doesnt exist, too.)

 

Thanks for all tips.

 

Bye.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...