Jump to content
Welcome to our new Citrix community!
  • 0

No Desktops on Web Storefront - 1912 LTSR


Chris Wells1709159337

Question

Hello--hoping someone can point me in the right direction.  I've installed single server setups a bunch of times.  Running Server 2016 w/ Virtual Apps and Desktops 7 1912 LTSR.  Running on HTTP for time being.   Installed VDA and they are registering with the Controller.  Figured i was in the clear....except when setting up the Delivery groups, when i login to the Storefront Website w/ username/password----there are no desktops from the delivery groups presented.    Using AD groups, and users....not seeing anything.

 

Figuring it's likely something happening on the back-end, as this is a fairly locked down environment, so there's probably something in their server GPO/lockdowns that might be breaking this.   Tried adding NETWORK SERVICE/LOCAL SYSTEM to the local admin group, as that worked back in the Presentation server days.

 

Locally hosted SQL EXpress DB.  Not seeing any app/system events that usually lead to something like the "Trust REquests sent to XML Broker" or whatever that was.

 

Any ideas on where to trace this down?   Account authenticates---but it's not finding any entitlements in the delivery groups---even with them being wide open to any users.

Link to comment

4 answers to this question

Recommended Posts

  • 0

Have you specified FQDN (and not merely hostname or IP) for the controllers in the list and could you also open up a web browser on your Storefront? and browse to the https://fqdn address you used earlier. Could you check if you get cert warning? 

Link to comment
  • 0

Originally it was configured for HTTP---but we also tried HTTPS when we had a valid machine cert installed and bound to IIS.  

It is definitely a GPO /lockdown policy causing the issue.  A new server was stood up and put in an OU that didn't apply all of the GPOs of the domain, and we did not have the issue.  

 

We are seeing a lot of events in the event log related to the DB not being available by the HA service, and the ConfigSync service not being able to import due to the database connection not being there.   Very odd.  The broker service starts up, and then 5 minutes later complains that the database connection is lost.  then service starts again and connects fine.  The DB is locally installed with SQL Express that came with the installation.  We have been through a ton of CTX articles related to the LHC db being corrupt, etc.  None of that worked.  

Everything is good on that server though without the GPOs applied---so hoping our ticket in with Citrix can help us narrow down the scope of what might be causing the issue.  I thought for sure it would be something small and stupid, but i've exhausted all of those things.  Unfortunately, we may have to apply these things one-at-a-time to see what is breaking it.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...