Jump to content
Welcome to our new Citrix community!
  • 0

MCS - Office and Windows KMS activation on a multi-session OS fails


EU IT Systems

Question

Hi Rob,

Once again thanks for the help yesterday. If you remember, i mentioned that i was having a nightmare with Office and Windows KMS activation on a multi-session OS. I got a message back from support today after they had taken some CDF traces while I created the MCS catalog and captured the KMS errors.

 

Both Windows OS and Office KMS failed as per the error on the catalog. I've followed all steps to get these successfully activated via MCS. We use Active directory based KMS activation. The OS and Office are activated when it is created, but that only happens if the catalog is new. If i update the image in an existing catalog, it fails with the same errors but does not actually create the machine. I'm not sure the message from support is adequate really and wondered if you had any suggestions on how to fix this. I am fully aware that i can turn off KMS activation on the catalog and knew that before I called them, but I don't like changing things I shouldn't have to change and the response seems a little lazy in my opinion. May be i've missed something again.

 

Message from support today:

---------------------------------------

Hi

 

Hope you are doing great!

I checked further on the same and it looks to be a cosmetic error though the windows and office are both activated on the MCS created VM.

I would suggest you to follow the below articles and let me know if that helps:
https://support.citrix.com/article/CTX233683
https://support.citrix.com/article/CTX206225

Please feel free to reach out if there is any query.
---------------------------------------

 

 

Link to comment

10 answers to this question

Recommended Posts

  • 0

In App Layering we have built in scripts that perform a slmgr /ipk <key> and slmgr /ato

Without those running every boot normally activation fails

Therefore unless you are using Citrix Cloud where you dont have control over whether MCS performs the os rearm then its always better to disable rearms when using app layering.

 

If you really want to do the rearm then you have to figure out why its  failing.  In your case it might be the fact that the Master Image is not really joined to the domain.  You can test this by taking your master image and resetting its domain account by moving it to a workgroup then back into the domain.  After that try deploying and see if its now successful.  If it is you can probably figure out how to script that process.  If I were going to do that i would not join the domain in the platform layer but instead would just script joining when the mast image boots.

 

But again id it were me i would disable the whole process as its not really needed.

Link to comment
  • 0

The legend has spoken. If you say i can safely disable it, then that's good enough for me Rob.  Thanks again for the quick response. I'm really starting to like AppLayering, so flexible, clean and easy to manage. Shame we couldn't get those User Layers in the Multi-session OS, would have been nice to keep it all under the Citrix banner. One last question. I think i heard you mention previously that it's always good practice to ensure you have a copy of a clean OS layer to fall back to if something goes wrong. What's your recommended way of doing this since there is no clone option on the OS layer in ELM?

Link to comment
  • 0

Hi Rob, sorry about delay. So have tried these commands and it doesn't seem to be able to do both at the same time on a catalog. When i run the below commands on the catalog, it only sets one or the other.

 

"Set-ProvSchemeMetadata -ProvisioningSchemeUid f3e21a70-5aa7-4931-b67e-7ff99923dc8d -Name ImageManagementPrep_Excluded_Steps -Value OsRearm"

 

"Set-ProvSchemeMetadata -ProvisioningSchemeUid f3e21a70-5aa7-4931-b67e-7ff99923dc8d -Name ImageManagementPrep_Excluded_Steps -Value OfficeRearm"

 

e.g. below you can see the properties of the catalog does not include both the rearms. because i ran the second command last, that it the only value that gets inputted into the metadata field:

 

Metadata : {ImageManagementPrep_DoImagePreparation = True, ImageManagementPrep_Excluded_Steps =OfficeRearm, ImageManagementPrep_NoAutoShutdown = False}

 

Am i doing something wrong? 

 

I tried running the same command on a single line with both values, it still only rearmed one of them and not both.

 

"Set-ProvSchemeMetadata -ProvisioningSchemeUid f3e21a70-5aa7-4931-b67e-7ff99923dc8d -Name ImageManagementPrep_Excluded_Steps -Value "OfficeRearm, OSRearm"

 

Am i doing something wrong here? I would prefer doing it this way as it's tiresome having to do it globally and then turning it back on again as other catalogs need it.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...