Jump to content
Welcome to our new Citrix community!
  • 0

Citrix receiver ERROR: "You have not chosen to trust "USERTrust RSA Certification Authority" on MacBook (version El Capitan)


Katinka Ladee

Question

Hi there,

 

Recently i've been facing the error ""You have not chosen to trust "USERTrust RSA Certification Authority", the issuer of the server's security certificate." when trying to log into Citrix Receiver. 

I'm using a MacBook Pro (2012), version 10.11.6 (OS X El Capitan) and tried it in both Google Chrome and Safari. On a Windows computer I can still log in, so it's a Mac problem...

 

I've tried updating all applications on my Mac, Citrix Reciever as well as downloading the Citrix Workspace app (version 1903.1 for Mac which should be compatible with El Capitan, and of course after uninstalling Citrix Receiver), but still I get the same error...

 

Can anyone please help me out? Is it maybe that an update to a Mac OS X 10.12 or more is necessary to use Citrix nowadays? 
Thank you so much in advance!

 

Katinka

Schermafbeelding 2020-06-04 om 16.30.59.png

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...