Jump to content
Welcome to our new Citrix community!
  • 1

audio devices are dropped after session reconnect


Question

Hey there ...

after updating from Horizon 7.8 to Horizon 7.12 ....

 

We use ELM 20.3.0.12 and are using elastically assigned layers.

 

I have the following problem:

When I reconnect to a session, all vmware and teradici audio devices are gone.

The user has no sound input or output anymore.

Attached USB devices such as webcams remain. 

 

I did some testing and found out:

If I set the reg key: unirsd -> start = 4 than the problem is solved.

 

Is this a known problem ? Any idea what I can do ?

I guess it is a bad idea to not start that service ?

 

 

Chris

 

CTX Case #79779738

Link to comment

12 answers to this question

Recommended Posts

  • 0

Good morning Rob,

 

I have tried recreating a new platform layer with agent version 7.12 as well as with agent version 7.8 to compare if the behaviour ist the same.

Unfortunatly the problem remains and is reproducable.

 

I sent some screenshots within the Case #79779738 where you can see, that there is a difference how the audio devices are presented within the device manager between 7.8 and 7.12.

The audio devices are coming soley from the agent, so I guess vmware changed something there.

 

Chris

Link to comment
  • 0

I wanted to add that we're also experiencing this issue.  We upgraded our VMware Horizon server from 7.9 to 7.12.  We captured a new version of the platform layer with the new Horizon Agent, and that's when we started experiencing this issue.  If a user signs out of the desktop, there's no issue, but if they just disconnect, when they sign back in both the VMware and Teradici audio drivers will be gone.

 

We tried capturing a new platform layer from scratch but that didn't solve the issue.  We rolled back to our previous image, and it restored the VMware drivers, but not Teradici.  Ultimately, we had to wipe users layers and keep using Horizon Agent 7.9 in order to make things work.  I've also tested this using a fresh platform layer with Horizon Agent 7.11 and experienced the same problem.

 

I have an open case with Citrix Support about this (#79715762), but it's nice to know we're not the only ones with this issue.  We've been running fine for a number of weeks with Agent 7.9 so for anyone else having this issue, you may be able to work past it this way.  In the meantime, we'll wait for the official fix before trying to upgrade the Agent again.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...