Jump to content
Welcome to our new Citrix community!
  • 0

Xenserver 7.1. CU2 cannot create multipathing


vbanjeg46

Question

Hi guys,

 

I'm having some problems with 2 hosts in a pool.

Yesterday I tried to enable multipathing.

Host is in maintenance mode and I clicked on : ''Enable multipathing on this server''.

I got error:  ''The SR failed to complete the operation''

 

I can't find anything usefull on internet about this strange problem.

Link to comment

8 answers to this question

Recommended Posts

  • 0
4 minutes ago, Alan Lantz said:

Is your SR that you are using for the Heartbeat a shared SR and is it marked as a default ?

Yes.

I also tried (for test ) it on a standalone host with the same SRs and it went without a problem.
And on the two hosts that are in the pool I get an error.

 

4 minutes ago, Alan Lantz said:

 

--Alan--

 

 

Link to comment
  • 0

Please can you explain me, sorry but I'm new at this so I need to ask.

 

But....

These hosts are in production, everything is working fine, VMs and templates are on that LUNs, so I don't think that is a problem.

 

I tried to test it yesterday...

I have one host which is standalone at this moment.

And I tried to enable multipathing with same LUNs and everything went smoothly.

 

So only diffrence beetwen that host and other two is :

- one is standalone (everything works fine)

- two are in the pool ( I got error when I tried to enable multipathing)

Link to comment
  • 0

The two hosts just need to have a common pooled SR, evidently an iSCSI device in your case. Hard to say what the issue might be if both hosts can access the SR and have a common network for management as well as storage, and are properly synchronized to NTP. Do you see any more detailed error messages in /var/log/SMlog ?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...