Jump to content
Welcome to our new Citrix community!
  • 2

Ubuntu 20.04 Workspace2004 no audio or webcam in CitrixDesktop


David Baranowski

Question

Hello everybody,

 

right now im trying to use MS Teams via CitrixDesktop from my Ubuntu 20.04 Client. I installed the latest workspace app (2004) and the usb support package. 

But it looks like there is no audio device in my CitrixDesktop... I tryed some changes in the module.ini (nothing happened) and in the wfclient.ini (AllowAudioInput=True)

 

After the setting in the wfclient.ini the citrix desktop shows a microphone in the audiosetting, but thats all. I cant use it.

Are there some other settings i need to do before i can use Teams with microphone and webcam?

 

PS: Local, everything works fine. From an Windows 10 PC too...

 

 

Link to comment

2 answers to this question

Recommended Posts

  • 0

I have similar but audio works fine both when I connect from HP windows laptop to citrix desktop Windows 10 VM OR from my Linux Kubuntu 18.04.4 LTS  desktop to the Win10 VM...

 

What I cannot make to work on both is to pass through WebCAM (which works fine locally (e.g. in Slack) both on Linux and Windows but Citrix does not recognize and pass it to Windows 10 VM) So I use MS Teams without Video ...

Link to comment
  • 0
On 5/22/2020 at 5:14 PM, David Baranowski said:

Hello everybody,

 

right now im trying to use MS Teams via CitrixDesktop from my Ubuntu 20.04 Client. I installed the latest workspace app (2004) and the usb support package. 

But it looks like there is no audio device in my CitrixDesktop... I tryed some changes in the module.ini (nothing happened) and in the wfclient.ini (AllowAudioInput=True)

 

After the setting in the wfclient.ini the citrix desktop shows a microphone in the audiosetting, but thats all. I cant use it.

Are there some other settings i need to do before i can use Teams with microphone and webcam?

 

PS: Local, everything works fine. From an Windows 10 PC too...

 

 

Hi,

 

Your ubuntu is it set in local language or in english ?

We solved our problem when we set thinclient language from local (french) to english.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...