Jump to content
Welcome to our new Citrix community!
  • 0

W10-1809 CPM 1912 start menu breaks sometimes


Question

Not sure when this started, perhaps on vda 1912 upgrade, win10 1809 ltsc fully patched with cpm, no fslogix or anything else.  users will sometimes have a blank start menu as shown below on logon, the fix is to pin a desktop icon to the taskbar or restart explorer from task manager.  it doesnt break on every logon, sometimes the menu is fine, other times it is not, nothing in the event viewer for cpm either.  ideas?

 

broken.jpg

Link to comment

7 answers to this question

Recommended Posts

  • 0

I had the same and 'solved' it.

I used Folder Redirection for the start menu.

My Windows environment is Server 2019 and Citrix is 1912 LTSR CU1 for all components. But I think the same issue will occur on 2016 or Win 10 because of the codebase.

 

My first error was my own: typo in the redirection path, no permissions to create the folder - oops...

Whatever I did according to James or Carl's blogs, it never worked 100%, only about 50-80%.

 

Fix for me in the end:

Well, not really a fix, but ah well. I chose to delete all cached profiles after a user logoff. This worked for me!

 

The thing is, it's probably a timing issue. I don't know if it's a Citrix or a Microsoft issue.

Try gpupdate after logging in. Dit that fix your menu?

Try killing explorer.exe and run it again. Did this fix it as well?

Then timing issue.

 

Two solutions. (workarounds)

1) The one from above, delete cached profiles after logoff.

2) Run gpupdate from registry->Run, Startup folder or Logon script (GPO)

 

Edit:

Hmm, another thing. After a profile reset, does it show the menu again? Still timing issue. This is how I came to the 'delete cached profile' solution.

 

As a side note. The 3 or 4 icons you see will always remain, don't try to remove then. This 'empty' start menu could also be created by certain Group Policies, but I think you did that on purpose and want to show icons from the user profile right?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...