Jump to content
Welcome to our new Citrix community!
  • 0

Xenserver 7.1 cu2 has lost connectivity to Pool


vbanjeg46

Question

HI,

I really need your help. Here is situation.

We have 13 XenServer 7.1 CU2 (server is Lenovo SN550) added to a one pool. And one, for no reason has become unreachable (red in XenCenter). We reinstalled it and problem is when we want to add it to a pool.

Network is bonded (0+1) and bond is LACP  with load balancing based on source mac address, everything work fine when host is out of pool (acts as standalone).

When we try to add it, bond turns in Disconnected and the host become unresponsive

 

We asked Citrix support for help and here is what we have done:

 

- Checked NIC interface rename logs, there are no mac changes on hypervisor level.
- Verified network driver version, it was on same version as hosts in pool. (be2net ver.11.2.1226.2, fw 12.0.126.0)

- checked switch side, everything is ok

-poblematic  host is on same patch level as pool

- Citrix support claims it is a hardware error - we contacted Lenovo support and they  replaced  motherboard and NIC 

 

And the problem still persists.

 

What can we do next, we are struggling for two months

 

Thank you in advance

 

 

Link to comment

21 answers to this question

Recommended Posts

  • 0

I checked NTP and It is set up same as other.

Do the dom0 instances have adequate memory allocated to them? - can you please tell me how to check it ?

It is blade server and Lenovo support has changed motherboard and NIC.

They claims that is a Citrix issue, Citrix claims that is a hardware failure :)

 

Can I upload logs here, can someone analyze them ?

Link to comment
  • 0

The memory allocation looks fine. Are the hosts all at the same hotfix levels? That's also important when joining a host to a pool. Also, I waned to ask if this host has a very similar or identical architecture (CPU type) as the other hosts in the pool? They all have to be exact or at least very close matches in order to be members of a pool. You can check the characteristics of each host with the command "xe host-cpu-info".

 

-=Tobias

Link to comment
  • 0

@ Alan- you think join from shell, not from XenCenter ?

             - we tried with new name/ip; same thing

 

@ Tobias - hotfix level is same on all hosts

                 - hosts are identical (Lenovo SN550)

 

Thank you guys, I really apreciate your effort.

Link to comment
  • 0

We are troubleshooting whole weekend but we don't have progres.

 

We created new pool with problematic host's.

Pool master succesfuly works on bonded network but any slave host just doesn't work.

 

We tried put in the pool without bond, with previously created bond...... same thing.

 

But, if  I put that slave hosts outside of pool, they work with bond (as standalone host's).

 

That is a little bit confusing.

Link to comment
  • 0

Of course, these are requirements.

But even a Citrix support guy was desperate and tried other way :)

 

What could be wrong ?

 

Just to summarize:

-we have three identical hosts: ThinkSystem SN550, Machine Type 7X16

-HW is identical

-NICs are identical (Emulex Corporation OneConnect NIC (Skyhawk))

- hardware is not a problem, we changed the hardware components

-The driver and firmware versions on the NICs are the same

 

We have tried,several ways to create a bond:

                - at the pool level and then we added slave hosts to the pool

                -standalone host with bond created and then added to pool

 

note: when we create a bond on a standalone host, the bond works properly

 

We currently have hosts in the pool without a bond.

But that is not option for a longer term.

Link to comment
  • 0

The bond should be automatically created when the new host is added to the pool. I think we already covered that NTP is properly synchronized, the hotfixes are the same, and the primary management interface was on the same NIC in terms of slot order.

I'd use the CLI to investigate the pif-list and network-list to verify what networks are visible on both. This article, among others, may help:

https://www.practicalxenserver.org/tutorials/scenario-2/tutorial-2-part-2/

Also, check in /var/log/* (might have to look in several) for any network-related messages that might help sort things out.

 

Finally, do you have any multipath settings anywhere that are active and if so, are they active on all hosts on the pool?

 

-=Tobias

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...