Jump to content
Welcome to our new Citrix community!
  • 0

Frequent Citrix HDX RealTime Connector Drop-outs


Mate Beros

Question

Hi,

I'm currently using Citrix HDX RealTime Connector 2.6.0.2030 on my virtual desktop which is running on Windows 7 Professional SP1 64-bit.

The host computer I am running this session on is using Citrix HDX RealTime Media Engine 2.6.0.2030 which is running on elementary OS 5.1.4 Hera.

Every two minutes the connector disconnects, the media engine disappears from the status and command line output is as follows:

 

couldn't read configuration file /var/lib/RTMediaEngineSRV/settings.conf trying to create one...
couldn't read configuration from a file /var/lib/RTMediaEngineSRV/settings.conf
ioctl (HIDIOCGSTRING): Invalid argument

 

I have tried to set permissions for the folder and the settings conf to read,write and execute for user profile.

The settings.conf file gets overwritten with a new file every ~ two minutes / whenever the drop out occurs.

 

Can anyone shine a light on what I can do to fix this as apart from this, my linux desktop is running my virtual desktop perfectly.

 

Thanks,

 

Matt

 

Link to comment

3 answers to this question

Recommended Posts

  • 0
On 5/19/2020 at 7:26 PM, Daniel Szomboti said:


Hi Matt. 

This version of Deb was never tested. I guess you don't face same with a normal Ubuntu flavour? 

I will raise it with QA team but for now it's untested and therefor not supported :( 

 

Hi Daniel,

 

Thanks for your response. Turns out that it actually relates to a bug that you acknowledged on another discussion where RTME crashes if IPv6 is active.

 

Disabling IPv6 has fixed this issue.

 

Thanks,

 

Matt

  • Like 1
Link to comment
  • 0
4 hours ago, Mate Beros said:

Hi,

I'm currently using Citrix HDX RealTime Connector 2.6.0.2030 on my virtual desktop which is running on Windows 7 Professional SP1 64-bit.

The host computer I am running this session on is using Citrix HDX RealTime Media Engine 2.6.0.2030 which is running on elementary OS 5.1.4 Hera.

Every two minutes the connector disconnects, the media engine disappears from the status and command line output is as follows:

 

couldn't read configuration file /var/lib/RTMediaEngineSRV/settings.conf trying to create one...
couldn't read configuration from a file /var/lib/RTMediaEngineSRV/settings.conf
ioctl (HIDIOCGSTRING): Invalid argument

 

I have tried to set permissions for the folder and the settings conf to read,write and execute for user profile.

The settings.conf file gets overwritten with a new file every ~ two minutes / whenever the drop out occurs.

 

Can anyone shine a light on what I can do to fix this as apart from this, my linux desktop is running my virtual desktop perfectly.

 

Thanks,

 

Matt

 


Hi Matt. 

This version of Deb was never tested. I guess you don't face same with a normal Ubuntu flavour? 

I will raise it with QA team but for now it's untested and therefor not supported :( 

Link to comment
  • 0
On 5/19/2020 at 10:26 AM, Daniel Szomboti said:


Hi Matt. 

This version of Deb was never tested. I guess you don't face same with a normal Ubuntu flavour? 

I will raise it with QA team but for now it's untested and therefor not supported :( 


Hi Matt.

 

Yes Ubuntu is fine and tested extensively. Ohhh you ran into the Ipv6 one :) 

We have that in plan to sort out, it's on the bugs list. Don't have an ETA for it but it will be sorted in next updates. 

 

Regards,

Daniel

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...