Jump to content
Welcome to our new Citrix community!

RDP proxy with windows 10 2004


Recommended Posts

has anyone else tried windows 10 2004?  I'm on the preview build, which is only a couple of weeks away.

 

i noticed since the upgrade the RDP client refuses to work with the RDP proxy on the netscaler.  it just presents an internal error.

 

I've opened a ticket with microsoft about it.  we've got a lot of employees relying on this for remote access.

 

specifically, the mstsc.exe built into windows doesn't seem to work.  the UWP app in the windows store does seem to work though.  not sure if they removed support for token based authentication in the new version or something.

 

 

Link to comment
Share on other sites

  • 3 weeks later...

We had 3 of our users who recently upgrade their Home PC to Windows 10 version 2004 and since the upgrade RDP client refuses to work with the RDP proxy on the NetScaler. 

The error received is "An Internal Error has occurred"  (Note: Published Remote Desktop via Virtual Apps works fine on Windows 10 Ver 2004)

 

I've opened a Ticket with Citrix Netcaler support, they have collected the logs for further investigation.  

The mstsc.exe built into windows doesn't seem to work. Not sure why this is causing not to connect. 

 

If anyone opened a ticket with Microsoft, did they give any solution on this ?

Link to comment
Share on other sites

reposting here from the other thread.

 

yeah i opened tickets with microsoft and citrix a couple of weeks ago.  i noticed the problem in the preview release.

 

Citrix closed the ticket and said "we don't support that version until it's released".  completely unhelpful.

 

Microsoft took some debug traces and got their developers involved.  there's a patch coming out in june that fixes it.

there's a registry key workaround:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Terminal Server Client

SendCorrelationId = 0

type dword

 

microsoft also mentioned they'd work with citrix to ensure a future version of the netscaler rdp proxy properly handles the rdp protocol.

 

Another workaround is to use the windows 10 store version of the remote desktop client.  the UWP version seems to work ok for whatever reason.

Link to comment
Share on other sites

just installed junes update for windows 10 2004.  the registry key fix is no longer necessary.

 

however the SSO still doesn't work, it will prompt for a password.  i think at this point it's a citrix issue with the way they handle the RDP protocol.

 

https://support.microsoft.com/en-ca/help/4557957/windows-10-update-kb4557957

 

the patch notes don't mention this issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...