Jump to content
Welcome to our new Citrix community!
  • 0

Microsoft Teams Citrix HDX Optmisation - Auto-start Issues


Jason Nash1709151307

Question

Hi All,

 

We have been testing this and from our limited testing this appears to work very well. Shame only for Windows right now.

 

One issue we have found is if Teams is left with the default 'Auto-start application' on login often Teams starts without the HDX optimisation (when checking About > 'Version Citrix HDX Optimized' is not present).  If you then fully close/exit Teams and immediately relaunch it then starts with the HDX optimisations operational. It seems as if Teams is starting too soon on login before the Citrix components have had chance to initialise.

 

Has anyone else come across this issue?

 

Jason

Link to comment

9 answers to this question

Recommended Posts

  • 0

We have found that, even without Teams starting on logon, HDX optimization does not work the first time Teams is launched. 

 

So even if the user logs in, waits 2 minutes and launches Teams, they almost always have to quit and relaunch for it to be optimized. Sometimes they have to launch three times; it is intermittent. 

 

This is on Virtual Desktops 1912 on Server 2016.

Link to comment
  • 0
Just now, Adam Reid said:

We have found that, even without Teams starting on logon, HDX optimization does not work the first time Teams is launched. 

 

So even if the user logs in, waits 2 minutes and launches Teams, they almost always have to quit and relaunch for it to be optimized. Sometimes they have to launch three times; it is intermittent. 

 

This is on Virtual Desktops 1912 on Server 2016.

 

This does sound like a Teams problem.

After the user waits 2 min and launches Teams, what does he see when clicking About/Version?

Link to comment
  • 0
6 minutes ago, Fernando Klurfan1709153904 said:

 

This does sound like a Teams problem.

After the user waits 2 min and launches Teams, what does he see when clicking About/Version?

 

He would see 'You have Microsoft Teams Version 1.3.00.4461 (64-bit). Citrix HDX Not Connected. '

 

After quitting Teams and restarting it, thus would change to optimized.


We have a ticket open for Citrix but have not made any progress after 2 weeks.

Link to comment
  • 0
Just now, Adam Reid said:

 

He would see 'You have Microsoft Teams Version 1.3.00.4461 (64-bit). Citrix HDX Not Connected. '

 

After quitting Teams and restarting it, thus would change to optimized.


We have a ticket open for Citrix but have not made any progress after 2 weeks.

 

Even though you see "Citrix HDX Not Connected", what happens if you go to Settings/Devices in Teams, do you see your self-preview?

Link to comment
  • 0
Just now, Fernando Klurfan1709153904 said:

 

Even though you see "Citrix HDX Not Connected", what happens if you go to Settings/Devices in Teams, do you see your self-preview?

 

Yes, just tested and strangely we do. The preview appears to work?! Is the status a red herring?

Link to comment
  • 0
Just now, Adam Reid said:

 

Yes, just tested and strangely we do. The preview appears to work?! Is the status a red herring?

 

Yes, seems like it. Sometimes the Teams UI is not syncing correctly. Any action that requires optimization (like webcam display in the self preview window, or even a call) will trigger the mechanisms in Teams/VDA to optimize. If you then click again About/Version, you will see "Citrix HDX Optimized"

This is documented in the "Live updates" section in CTX253754

Link to comment
  • 0
On 5/19/2020 at 8:53 PM, Adam Reid said:

 

He would see 'You have Microsoft Teams Version 1.3.00.4461 (64-bit). Citrix HDX Not Connected. '

 

After quitting Teams and restarting it, thus would change to optimized.


We have a ticket open for Citrix but have not made any progress after 2 weeks.

 

Sounds similar to our issue. We have HDX webcam redirection enabled so you have to be careful just checking Devices to see if the webcam preview is present. In our case when it states Citrix HDX is not connected or similar we still see a video preview but via standard HDX redirection. In order to be sure I usually screen print the window, if the video shows as a blank box I know that the Teams Optimization is operating. Not had chance to test again this week. Interested to hear how you get on with this one?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...