Jump to content
Welcome to our new Citrix community!
  • 2

Unable to use smartcard on 20.04

Daniel Shub


5 answers to this question

Recommended Posts

  • 1

I use Arch Linux to connect to a virtual machine with the workspace-app. I have no problems using the smartcard on my Arch Linux machine. The machine uses opensc, ccid and pcsc-tools and does not use coolkey.


The virtual machine I connect to with the workspace app is running Windows 10 and I have no privledges on that machine. When using version 19.12 of the workspace app to connect to the virtual machine I can access websites that require smartcard authentication without any problems on the virtual machine. When connected with 20.04, the Windows dialog repeatedly tells me to insert the smartcard. I have tried connecting with the USB smartcard reader connect to my local machine prior to and after connecting to the remote Windows machine. I have tried intserting the smartcard before connecting, after connecting but before starting a web browser, after starting the web browser but before going to the secure website, and after going to the secure website. I have tried Edge, Chrome and Firefox.



  • Like 1
Link to comment
  • 0

More details about how you're "unable to use" your smartcards would be helpful!  But the first thought I had is newer distros are starting to use p11-kit instead of every app maintaining it's own truststore.  Is 20.04 using OpenSC or Coolkey or something else?  Is it still using pcscd to read cards?  Are you sure your reader is supported or that there isn't a driver you're missing?

Link to comment
  • 0

Hi daniel_shub !

Exactly the same for me, see some posts above.

I use workspace app 20.04 on Ubuntu Mate 20.04 LTS, 64bit Firefox, opensc 20.01 as well.

I can 100% confirm the behavior of your client.


I'd like to see at least an official comment from Citrix in here, please!

I mean: This is not an open-world forum but more like a vendor-driven thing.

There should be some hints what to check.


As from today I see 20.06 of Windows workspace app, but no news on corresponding Linux app.


Well, I got my connection working with 32bit Firefox and ArmHF workspace app on a Raspberry Pi 4 without any flaws.

I cannot use the Microsoft Teams optimization but that is not such a big pain point.


I bet my bottom dollar that you would succeed if you used an 32bit Arch. But who wants this nowadays?

Link to comment
  • 0

Same on gentoo Linux. 20.04 and 20.06 do not work, while 19.12 does. It is clearly connected to updating the workspace app since downgrading fixes the issue.


The test setup is a browser on the Windows VM. It does not seem to "see" a smartcard it can work with. On the client it is opensc where everything works as expected (i.e. a browser on Linux can use the smartcard)

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...