Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Workspace crashing - Windows 10 GeForce GTX 970


Ciaran Martin

Question

I'm running Windows 10 with a GeForce GTX 970 Graphics card and connecting to Citrix using Citrix Workspace 20.2.0.25. I am connecting to my work PC through Citrix.

 

However twice today when selecting the Citrix session having been focused on my own PC, the entire machine freezes and I'm unable to recover it.

 

I was on Nvidia Graphics drivers 432.00 and upgraded to 442.74 just now.

 

I'm looking for some help in figuring out what is happening. I've tried setting logging on the Citrix session but that doesn't seem to work https://support.citrix.com/article/CTX132883#1

Link to comment

5 answers to this question

Recommended Posts

  • 0

I'm running Citric Workspace on a newly built PC with a clean install of Windows 10. Everything Windows and Citrix is running the latest versions.

 

My entire PC freezes - I'm unable to do anything so have to do a hard reset. When I log back into Citrix my session was there as before running without issue.

Link to comment
  • 0

I am having the same issue... Brand new built PC - RFX 2070 Super Graphics Card (Latest Drivers installed), AMD 5950x CPU, 2 x 4K Monitors - Windows 10 20H2 - Citrix 20.10.0.20.  The issue seems to occur when switching between full screen and windowed or vice versa. When it happens the menu bar shrinks to about half the normal size and the PC locks. Only option, as ringzer stated, is to restart the PC. I have had a look in the event viewer and unable to see anything which might help understand the problem.

Link to comment
  • 0

When I was using the Windows 1909 version this problem did not happen, however it was only to upgrade to the Windows version 20H2.
When I open the session to enter the user / password credentials the remote session and my local laptop with the new version of Windows freezes completely.

Microsoft Windows 10 Pro 64 bits 20H2 [version 10.0.19042.630]

Citrix Workspace 20.10.0.20(2010)
Laptop Dell Vostro 3583 Intel(R) Core(TM) i5-8265U CPU @ 1.60GHz   1.80 GHz (8 Gb RAM) / SSD 256 Gb

Citrix login freeze.jpg

Citrix task freeze.jpg

Edited by Roberto Escher
Informations update
Link to comment
  • 0

Hi, I have been facing the same issue and found a fix on reddit that seemed to be working for me.

Quote

Try this fix, worked for me. Same exact issue as you!

Set this registry key.

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\GfxRender] "UseD3DHybrid"=dword:00000000

 

Edit: If you don't have this registry key, add a new one and set it.

 

All Credits: Reddit Post

Edited by Necil Dabre
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...