Jump to content
Welcome to our new Citrix community!
  • 0

Upgrade from 7.15LTSR to 1912 LTSR. Unable to open "Machine Catalogs" in Studio.


Aliaksander Stupin

Question

  Hi. Upgrade was successful and was made rightly according to manual. All tests are passing fine in studio (site, catalog, delivery group). I'm able to open SQL bases through SQL management studio. No mistakes in Citrix Director. I even able to create new Machine catalog. Everything is fine but i'm unable to open machine catalogs in Studio. Here is the mistake:

image.thumb.png.9b1bb5e3fc8c9fb8f12fa12f5dd2a1ca.png

 

Error Id: XDDS:47EB21CB

Exception:
    Error Source : Citrix Studio
    
    StackTrace: Citrix.Console.Common.CitrixAggregateException One or more parallel operations failed
       в Citrix.Console.Common.CitrixParallel.InternalForEach[TIn](IEnumerable`1 items, Action`1 operation, Int32 maxSimultaneous)
       в Citrix.Console.CommonControls.ViewModelBase.<>c__DisplayClass90_0.<RunBackgroundTask>b__0(Object s, DoWorkEventArgs e)
    
Inner Exception:
    DesktopStudio_ErrorId : DataStoreException
    SqlErrorText : 
    SqlErrorNumber : 0
    ConnectionString : 
    DataSource : 
    Error Source : CitrixAppLibrary
    Sdk Error Message : The database configured for this service is an invalid state. The operation could not be completed as the Database configured for the CitrixAppLibrary service is not available or cannot be contacted. Check that the service database is running, verify your credentials and ensure you have permissions to access the database and that the database is not being upgraded. Hint: A DALDataStoreException occurred.
    Sdk Error ID : Citrix.XDPowerShell.Status.DataStoreException,Citrix.AppLibrary.Sdk.Commands.GetAppLibAppDNAConnectionCommand
    ErrorCategory : NotSpecified
    DesktopStudio_PowerShellHistory : GetAppDNAConnectionScript
    25.04.2020 8:40:44
    
    Get-AppLibAppDNAConnection  -AdminAddress "xdc1.elko.by:80" -BearerToken ********
    Get-AppLibAppDNAConnection : The database configured for this service is an invalid state. The operation could not be completed as the Database configured for the CitrixAppLibrary service is not available or cannot be contacted. Check that the service database is running, verify your credentials and ensure you have permissions to access the database and that the database is not being upgraded. Hint: A DALDataStoreException occurred.
        + CategoryInfo : InvalidOperation: (:) [Get-AppLibAppDNAConnection], InvalidOperationException
        + FullyQualifiedErrorId : Citrix.XDPowerShell.Status.DataStoreException,Citrix.AppLibrary.Sdk.Commands.GetAppLibAppDNAConnectionCommand
    
    
    StackTrace: Citrix.Orchestration.Base.LogicModels.Exceptions.ScriptException Cannot communicate with the database. Check that the database is running and that it is not being upgraded. Make sure you have permission to access the database.
       в Citrix.Orchestration.Base.PowerShellInteraction.CmdletExecutionMethods.CreateException[T](ICommonLog logger, ExecutionResults`1 results, ICmdletExecutionHost host)
       в Citrix.Orchestration.Base.PowerShellInteraction.CmdletExecutionMethods.Execute[T](ISdkCmdlet`1 sdkCmd, ICmdletExecutionHost host, Boolean allowFailover)
       в Citrix.Orchestration.Base.PowerShellSdk.AppDiskService.Scripts.GetAppDNAConnectionScript.RunScript()
       в Citrix.Orchestration.Base.PowerShellInteraction.PowerShellScript`1.Run()
       в Citrix.Orchestration.Base.PowerShellSdk.AppDiskService.PSAppDiskService.TestAppDNAConnectionEnabled()
       в Citrix.Console.ProvisioningSchemes.UI.Mmc.ProvisioningSchemesTabViewModel.<OnRefresh>b__14_3()
       в Citrix.Console.Common.CitrixParallel.<>c__DisplayClass5_2`1.<InternalForEach>b__0(Object arg)
    
 

Link to comment

8 answers to this question

Recommended Posts

  • 2

Hi, we had exactly the same issue as described above.

Called Citrix Support and we managed to remove APPDNA from the deployement (we do not use it anymore).

Open an administrative Powershell on your Delivery controller

asnp citrix*

Get-ApplibDBConnection

=> this command should return a valid connection string

To remove APPDNA from Studio enter:

Remove-AppLibAppDNAConnection

 

Restart Studio and the Machine Catalogs displayed correctly.

  • Like 2
Link to comment
  • 0

In my case the reason was in SQL server. It was migrated from one host to another and it's IP changed. Meantime there were no mistakes and nothing suspicious in director and controllers at all.  Even site migration came fine from the  first sight. I understood the problems in SQL only after instigating the logs on database side.

     After all I made new citrix infrastructure in AWS with citrix ADC. And switch all machines there. I planed it long time ago :)   

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...