Jump to content
Welcome to our new Citrix community!

Citrix ADC VPX upgrade from 11.1.55.13 to 12.0.53.13 (installation package not existing in citrix site)


Recommended Posts

Hello all,

 

We wanted to upgrade a HA pair of VPX instances from 11.1.55.13 to 12.0.63.13. Unfortunately we faced the problem mentioned here.

 

We would like to upgrade to 12.0.53.13 at least, instead of upgrading the SDXs at this point, but we cannot find anywhere the .tgz file (installation package). It is not available in the Citrix site. 

 

Some information, 

  • ADCs are used for internal services and it's not our priority to patch CVE-2019-19781.  
  • We have admin partitions in this HA pair and we want flexibility in the resource allocation for new partitions.  
  • We want to upgrade in version 12.0.53.13 since we have already another instance in the same SDX in this version, so we are not worried about any issues

We have considered building a new VPX instance in the SDX with upgraded version and migrate the configuration, but it is pretty sure that a better way exists. 

 

Can we perform the upgrade using the .gz file from the other ADC?

How we can find older installation packages, more specifically 12.0.53.13?

Any ideas? 

 

Thanks in advance.

 

Link to comment
Share on other sites

You are right. 12.0 53.13 is not available any more. 63.13 is available. Any version before has well known and serious security issues, so Citrix removed these.

I would not install any 12.0 (no way I would "upgrade" to a totally outdated version), instead I would go with 12.1 56.22. It's stable, fast and has some good "new" features.

 

Greetings from sunny Austria

 

Johannes Norz

CTA, CCE-N, CCI

Link to comment
Share on other sites

5 minutes ago, Johannes Norz said:

You are right. 12.0 53.13 is not available any more. 63.13 is available. Any version before has well known and serious security issues, so Citrix removed these.

I would not install any 12.0 (no way I would "upgrade" to a totally outdated version), instead I would go with 12.1 56.22. It's stable, fast and has some good "new" features.

 

Greetings from sunny Austria

 

Johannes Norz

CTA, CCE-N, CCI

 

Thanks for your reply Johannes! Greetings from Greece! 

 

Our main issue is that we want to avoid upgrading our SDXs at this point. Since our SDXs' release is 12.0: Build 53.6, I think that we will face CTX237009 again. 

It is a matter of what suits our current needs, rather than what we would do or recommend as best practice. 

Of course, we are planning to upgrade as soon as possible our SDXs and all their instances, but we need a temporary, not best, solution in the meantime. 

 

Link to comment
Share on other sites

3 minutes ago, Spyridon Karvouniaris said:

Our main issue is that we want to avoid upgrading our SDXs at this point. Since our SDXs' release is 12.0: Build 53.6, I think that we will face CTX237009 again. 

 

There is no need to upgrade the SDX. You may even run a 13.0 on top of your SDX. Don't worry. It's common to have SDX image elder than VPX images.

 

Greetings

 

Johannes Norz

CTA, CCE-N, CCI

Link to comment
Share on other sites

1 hour ago, Johannes Norz said:

There is no need to upgrade the SDX. You may even run a 13.0 on top of your SDX. Don't worry. It's common to have SDX image elder than VPX images.

I know. It was the first time that we encountered such issue. 

I will try tomorrow upgrading to 12.1 56.22 and hopefully be back with... kudos. 

 

Greetings.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...