Jump to content
Welcome to our new Citrix community!

Netscaler VPX w Storefront


Frank Puma

Recommended Posts

I am having a strange issue i just cant get figured out.  I am still on a xenapp 6.5 enviroment.  I am running a Netscaler VPX running 11.1.67.  We are using Web Inerface 5.4 externaly through my netscaler.  I am doing a ica proxy.  Once you hit my external url it takes you right to the WI logon page.

 

I want to do the same thing with storefront.  i have a storefront server setup and working internally.  I am trying to do the same thing i am doing above with WI with SF.  I just cant see to get it to work no matter what i try.  I have been working on it for days.  The further i get is once i get passed to SF i get the Cannot complete your request.  When i look on the sf sever in the event log i see this message.

 

The strangest this is this directory doesnt exist on my SF server.  http://127.0.0.1/Citrix/RemoteAuth/CitrixAGBasic/Authenticate

 

A CitrixAGBasic Login request has failed.
Citrix.DeliveryServicesClients.Authentication.AG.AGAuthenticatorException, Citrix.DeliveryServicesClients.Authentication, Version=3.22.0.0, Culture=neutral, PublicKeyToken=null
Authenticate encountered an exception.
   at Citrix.DeliveryServicesClients.Authentication.AG.AGAuthenticator.Authenticate(HttpRequestBase clientRequest, Boolean& passwordSupplied)
   at Citrix.Web.AuthControllers.Controllers.GatewayAuthController.Login()

System.Net.WebException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
The remote server returned an error: (403) Forbidden.
Url: http://127.0.0.1/Citrix/RemoteAuth/CitrixAGBasic/Authenticate

 

Can anyone make any suggetions for me to get this up and running until i can get my enviroment upgraded?

 

Link to comment
Share on other sites

2 minutes ago, Sam Jacobs said:

What version of StoreFront are you running?

Are you using a callback in the NetScaler instance on StoreFront?

Are you load-balancing your StoreFront servers?

If so, do you have persistence set?

I was running 3.16.  I upgrade to the latest 1922 to see if that would help fix it.

I tried it with a callback url on the SF server.  I removed it since it said it was optional.  Same results either way.

No load balance

Link to comment
Share on other sites

Yes, keep the callback out.

Do you have an SSL certificate on your StoreFront server bound to IIS?

In your session profile, are you using HTTP or HTTPS in the Web Interface Address field?

916814676_NetScaler-PublishedApplications.thumb.jpg.fd90beee199cdf39fa41a49bf531a6b8.jpg

Are you using an FQDN or IP address in that field?

If you take the contents of the Web Interface Address field and put it into a browser, can you sign into StoreFront?

Link to comment
Share on other sites

2 minutes ago, Sam Jacobs said:

Yes, keep the callback out.

Do you have an SSL certificate on your StoreFront server bound to IIS?

In your session profile, are you using HTTP or HTTPS in the Web Interface Address field?

916814676_NetScaler-PublishedApplications.thumb.jpg.fd90beee199cdf39fa41a49bf531a6b8.jpg

Are you using an FQDN or IP address in that field?

If you take the contents of the Web Interface Address field and put it into a browser, can you sign into StoreFront?

I did add my wildcard ssl on the SF server and bound it in IIS.  Hoping that would change something.

I tired both http and https

I am using the FQDN

 

Yes.  I can log into my SF remoteWeb i am using in this case and can log in internaly without issue.

 

image.thumb.png.a1a8c6829552eab763438e21e35e48a2.png

Link to comment
Share on other sites

Just now, Sam Jacobs said:

I'm wondering if StoreFront is simply not compatible with XA6.5.  :38_worried:

It's not listed under System Requirements.

Thats the thing.  It works great internally.  Its just when i try to use it through the netscaler it wont work.  I find it strange that the error i listed in my OP about the path is not even on my SF server.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...