Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Workspace Not Working Through Hospital Websites After Recent Update - Help, Please, from Healthcare Worker Needing Access


Manas N

Question

I recently just updated Citrix Workspace as recommended. However, since then, I have been unable to open the Citrix Receiver/Workspace apps through my hospital websites (I work at two separate hospitals with separate EMRs that both use Citrix Workspace).  I have tried everything: the Citrix Clean Up Tool, adjusting the Registry, and even uninstalling.  However, when I try to uninstall, I get an error message saying "Global Document Path Cannot Be Retrieved."  I've tried even reinstalling Citrix Workspace, but the program recognizes it as already being installed.

 

Please help, as I need access to these apps to help me perform my work at the hospital, especially at this time.  I am running Windows 10.

Link to comment

5 answers to this question

Recommended Posts

  • 0

Hi,

 

What version of receiver did you upgrade to Citrix Workspace/Receiver App from? Also do you the older receiver version ?

 

Are you downloading app from Microsoft app store or citrix.com ?

I would suggest run Receiver Clean-Up Utility and check if application installed successfully. if yes reboot and try to reinstall. 

 

Thanks

Manoj

 

Link to comment
  • 0

Thank you, Manoj.   Even though I cannot uninstall Citrix Workspace ("Global Path Document not found"), it still shows up in my control bar shortcut icons as shown in picture below.

 

I currently have Citrix version 20.2.0.25 (2002).  The update was downloaded through the Workspace application itself checking for updates.  I originally downloaded Workspace from Citrix.com. Citrix Workspace had been updated from a previous Receiver version that we were using.

 

I used the Clean Up Utility again as you recommended (I had tried using before the uninstall everything) - but it does not do anything now, and just tells me to press a key to exit out. (Picture also attached)

 

Thank you so much.  I really appreciate it, and I am trying everything I can to resolve the problem.

Citrix Clean Up.jpg

Citrix Workspace still functional.jpg

Link to comment
  • 0

You don't say WHO recommended that you update Workspace.  If that request was not from the folks who actually support the Citrix sites, it's not necessarily a good idea to do so.  If the sites you are connecting to are older out of date environments, a newer version of Workspace may not work with them.  In my experience, for these older sites, this version typically works fine while still working with sites that are on current releases. https://www.citrix.com/downloads/citrix-receiver/windows-ltsr/receiver-for-windows-ltsr-latest.html .  In regards to installation of the software, always use the 'Rin as Administrator' option, and i believe you can force reinstallation of the current version if launched from the command line with /force.

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...