Jump to content
Welcome to our new Citrix community!

Storefront 1912 - clicking logout just refreshes page


Robert Cook

Recommended Posts

Hi,

 

Since updating Storefront to the 1912 LTSR whenever a user clicks logout from the storefront web page, it just seems to refresh the page and doesn't log the user off.

 

We authenticate to ADFS using SAML and it worked before the upgrade without any configuration change.  I have tried removing the custom changes from script.js and changing the NetScaler logout URL but it doesn't make any difference.  I've been through the other settings but cant find anything obvious.

 

Does anyone have any suggestions of what is likely to cause this so I can troubleshoot further?

 

Just to add after some further testing it does automatically logout back to the ADFS login screen after the session timeout limit is reached. 

 

Many Thanks

Link to comment
Share on other sites

Hi,

 

Please change the config file on the storefront.

 

C:\inetpub\wwwroot\Citrix\storenameWeb\

 

<workspaceControl enabled=”true” autoReconnectAtLogon=”true” logoffAction=”disconnect” showReconnectButton=”false” showDisconnectButton=”false” />

 

Change the value of logoffAction to one of the following settings:

  • disconnect (default) – Disconnects user from applications and desktops
  • terminate – Shut down user’s applications and desktops
  • none – leave sessions running and active after Storefront log off.

https://support.citrix.com/article/CTX200828

https://support.citrix.com/article/CTX136339

 

Thanks

Manoj

 

 

Link to comment
Share on other sites

3 hours ago, Manoj Rana said:

Hi,

 

Please change the config file on the storefront.

 

C:\inetpub\wwwroot\Citrix\storenameWeb\

 

<workspaceControl enabled=”true” autoReconnectAtLogon=”true” logoffAction=”disconnect” showReconnectButton=”false” showDisconnectButton=”false” />

 

Change the value of logoffAction to one of the following settings:

  • disconnect (default) – Disconnects user from applications and desktops
  • terminate – Shut down user’s applications and desktops
  • none – leave sessions running and active after Storefront log off.

https://support.citrix.com/article/CTX200828

https://support.citrix.com/article/CTX136339

 

Thanks

Manoj

 

 

 

Thanks for the suggestion, logoffAction was already set as disconnect and the other options make no difference.

Link to comment
Share on other sites

Hi,

 

After set this up to NONE can you  run the following command on storefront server can make sure it will return none.

 

 "C:\Program Files\Citrix\Receiver StoreFront\Scripts\ImportModules.ps1“
 $receiver = Get-STFWebReceiverService
 Get-STFWebReceiverUserInterface -WebReceiverService $receiver


image.thumb.png.f2e70a1c55eaa5a0c33e9a0305fbd335.png

 

Thanks 

Manoj

 

Link to comment
Share on other sites

On 4/17/2020 at 7:24 AM, Manoj Rana said:

Hi,

 

After set this up to NONE can you  run the following command on storefront server can make sure it will return none.

 

 "C:\Program Files\Citrix\Receiver StoreFront\Scripts\ImportModules.ps1“
 $receiver = Get-STFWebReceiverService
 Get-STFWebReceiverUserInterface -WebReceiverService $receiver


image.thumb.png.f2e70a1c55eaa5a0c33e9a0305fbd335.png

 

Thanks 

Manoj

 

Hi,

 

The LogOffAction is showing as none after making the changes in the config file

 

Thanks for you help!

Annotation 2020-04-20 093109.png

Link to comment
Share on other sites

  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...