Jump to content
Welcome to our new Citrix community!
  • 0

Native Workspace via MS Direct Access


Matthew Riddler

Question

Hello,

 

We have a citrix Xenapp 7-15  (all components are CU4, VDA's CU5 though).

As all of our staff are now working from home, we have a slight issue.

All machines that connect in to citrix are using Windows 10 with Direct Access (running on server 2016).

 

Are the latest workspace clients able to connect to citrix using IPv6 (as per DA design). I am using Workspace 1907.

We have a single URL that is used when in the office or out of it. When I am in the office (not using DA) & put the url in a broswer, it takes me to the storefront url. If I am using DA & go to the same url then it is taking me to the Netscaler Gateway we have setup. The gateway works fine for all of our systems that do not use DA.

I dont really want to be pushing everybody through the Gateway if I dont need to.

 

Now when working from home, all staff are getting your applications are not available at this time, when using the workspace app.

If I turn off DA I can launch applications using the workspace app.

To me it says DA cannot resolve addresses internally. DNS Resolution is set to true when I run get-brokersite.

 

I turned tracing on & the site is defining it as an inside site.

I have isatap adapter turned off on all of the servers in the citrix environment, would this potentially have an advantage of being turned on.

 

Has anybody else come across the issue? As I am sure lots of companies are now working from home.

 

Thanks

Matt

Link to comment

3 answers to this question

Recommended Posts

  • 0

When I ran a get-broker site to see that DnsResolutionEnabled: True

All servers resolve to IP's no problem using DA, store front, DDC's, all VDA's.

If I enter the name of the internal beacon into a browser I get a page cannot be displayed, as this normally redirects to the single url (accessible inside & outside of the LAN).

 

I am guessing I need to be able to get to this URL in a browser with no cert errors (it is using SSL), but has only a short name, not FQDN. I get the same if I put the FQDN in a browser.

Can I change the internal beacon using the reg key Computer\HKEY_CURRENT_USER\Software\Citrix\Receiver\SR\Store\1192228830\Beacons\Internal\Addr0 to be fqdn & also change to a different name completely.

 

Link to comment
  • 0

Matt

 

This is more about a (potential misconfiguration in DA than a Citrix issue.

Without knowing more about the naming of your internal domain, and the FQDN of your URL used to access your systems. I had a similar issue and had to DA to not pass through the external name of the URL when outside the network.

 

Regards

 

Ken Z

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...