Jump to content
Welcome to our new Citrix community!
  • 0

Error trying to run sysprep and the importance of machine SIDs


Sandy Williams

Question

Hello, trying to bring up some quick test servers using Layering publishing out to a XenServer (instead of our typical PVS deployment) and thought it was best practice to have a different machine SID so I tried to generalize with Sysprep. Getting an error almost immediately and the log is below.  I *did* try to do generalize a previous test deployment within AppLayering at the time of compiling my image and when it booted in Windows there was an error on the screen relating to sysprep'ing and I was basically in a reboot loop which is why I tried the manual sysprep after creating my server. This got me wondering about the necessity of Sysprep at all.  I read some opinions on forums about how its really only important when it comes to Domain Controllers and when you join it to a domain the domain will get it a unique ID so the machine SID doesn't really matter.  We run a large XenApp environment and I just grabbed the SID from 2 different images (same OS and Platform layer) that we deploy with PVS via Applayering and both had the same SID.  I always assumed PVS took care of any kind of uniqueness but I guess this makes sense.  Did I do something wrong with my deployment or is this normal?

 

2020-04-04 02:29:08, Error      [0x0f0082] SYSPRP ActionPlatform::LaunchModule: Failure occurred while executing 'EvtIntSysprepCleanup' from C:\Windows\System32\wevtapi.dll; dwRet = 0x3[gle=0x00000003]
2020-04-04 02:29:08, Error                 SYSPRP ActionPlatform::ExecuteAction: Error in executing action; dwRet = 0x3[gle=0x00000003]
2020-04-04 02:29:08, Error                 SYSPRP ActionPlatform::ExecuteActionList: Error in execute actions; dwRet = 0x3[gle=0x00000003]
2020-04-04 02:29:08, Error                 SYSPRP SysprepSession::Execute: Error in executing actions from C:\Windows\System32\Sysprep\ActionFiles\Cleanup.xml; dwRet = 0x3
2020-04-04 02:29:08, Error                 SYSPRP RunPlatformActions:Failed while executing SysprepSession actions; dwRet = 0x3
2020-04-04 02:29:08, Error      [0x0f0070] SYSPRP RunExternalDlls:An error occurred while running registry sysprep DLLs, halting sysprep execution. dwRet = 0x3
2020-04-04 02:29:08, Error      [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep cleanup providers; hr = 0x80070003
 

Link to comment

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...