Jump to content
Welcome to our new Citrix community!

STA down while using HTTPS on Netscaler


Recommended Posts

I know that this is a know issue and I tried the fix i found - > https://discussions.citrix.com/topic/382797-sta-down-when-using-https/

 

I ran -- set ssl parameter -svctls1112disable enable -montls1112disable enable -- but that gave me an error.  I had to change it to -- set ssl parameter -svctls1112disable yes -montls1112disable yes -- and I got no error. Rebooted the Netscaler and when changing them from HTTP to HTTPS I ran into the same issue. 

 

Any direction on this would help 

Link to comment
Share on other sites

Even though there is no strict advantage of SSL over HTTP with the STA, it should get up of course. There is nothing like a known issue.

 

There is one thing, that might affect SSL: If you enabled in "Traffic Management -> SSL" on the right side under Settings "Strict CA checks", you need to install the root certificate for the certificate used on your Delivery Controller (DC).

How to check your deployment:

 

  • Set up a service, type SSL, pointing to the DC. Is it up? If not: Check your firewalls! something is blocking SYN packets to flow from ADC to DC
  • Attach a monitor, typ https. Is it up? If not, you have problems with SSL (certificate not trusted, outdated, ...). Do a network trace and have a look at error messages during server hello, or server side change cypher spec.


I guess, this will solve your problems!

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...