Jump to content
Welcome to our new Citrix community!

Memory issue on NetScaler instance


Recommended Posts

Hello everyone.

 

We identified the following strange behavior in 2 customers:

 

Both customers are using NetScaler instance in Citrix SDX hardware and need to reboot the virtual instance regularly in few days to control the ram's memory usage,

 

Customer 1 is using LB, CS and GSLB. --> they were using 11.1 version and this issue began after update the firmware to 12.1-52.15

Customer 2 is using LB and CS --> Customer is using 12.0-60.9.

 

We can isolate this issue on customer 1 disabling Content Switching feature and it solved the question. so I'm thinking this might be causing any "memory leak" - but this feature is essential to this other customer.

 

We have tried versions: 12.0-60.9, 12.1-52.15 and 12.1-55.18 both the memory issue occurs.

 

I have sent numerous tech dumps and memory dumps to Citrix (#79476685 ) but they didn't find any solution for this issue.

 

I appreciate any suggestion to move forward this analyse.

 

Link to comment
Share on other sites

Hello,  It needs some analysis first if memory leak is actually been caused by content switching or any other module. Try running below at different hours to see if you observe any memory spikes.

 

root@ns# nsconmsg -d memstats | more

 

Check below and see if disabling appflow can help. I hope this could be fixed in upcoming releases if 12.1 55.18 is also not favoring it. 

https://discussions.citrix.com/topic/377375-high-memory-utilization/

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...