Jump to content
Welcome to our new Citrix community!
  • 0

PVS Uefi Boot


Question

Hello,

 

we have build an UEFI enabled vdisk and the vdisk is booting nice.

So everything working as planned.

 

Only one problem exists. And that is the Windows boot managers error which piles up. with every boot.

it looks like if Windows is creating a new boot entry for every boot because it cannot connect to the one specified. 

This happens only after Windows has loaded. so a reset before Windows loads, will not add up another try.

 

The question is, where does Windows get these entries from.

 

Tried the following to resolve this matter.

 

- This will only go away when creating a new vdisk. (it wil start with 1 boot entry)

- it wil nog go away bij copying the vdisk and assign this " new vdisk" on another device

- it happens after every reboot of a VMm, connected to that vdisk

I'm still in testing fase, but if anybody has a clue in how to solve this, please respond.

 

I can't find any information about this issue... but my opinion is that there are more people out there using EFI and PVS.

 

Ooh and for the information, this is happening in my homelab as it is happening in 3 customer installations.

 

PVS 1909 (also 1906 and 1903)

CVAD 1909 (also 1906 and 1903)

ESX 6.7

Windows 2016

 

(homelab boots from iso, and 2 of the customer locations also booting from iso, but production is booting from DHCP with scope options defined)

 

 

 Best Regards,

 

Herwin Duinkerken

30-4-2020 Herwin: Little extra information. This is still not solved. Created a case with Citrix (79612892) but they can't solve this so this case is closed. Now we have created a case with VMware. To be continued.

 

13-5-2020 Herwin. Still no solution, so I build a Hyper-v environment, created a Gen2 uefi boot vm (disable secure boot) and created a vdisk, after booting a couple of times, there seems no issue, but when you open up the settings from the vm, and look in the secttion Firmware, you see added up the bootmgfw.efi. So after selecting dvd to move to top, reboot, another file is created above the dvd boot, when selecting network boot, startup, then reboot, another file is created on top of the network boot order. (see attachement)

 

So i have created a  Xenserver environment, and created a vdisk and vm on Xenserver. boot a couple of times, from network or from DVD, there is no issue. but! a can't tell if i'm booting uefi or simple bios. My opinion is UEfi because of the pvsnbpx64.efi file wich is downloaded (see attachment) . But I do not have a lot of knowledge of Xenserver. 

 

If anybody out there is also running UEFI on Target devices and running PVS (does not matter if it is on hyper-v or VMware) I would love to know if these issues are also experienced.  

pvs-uefi-boot.JPG

pvs-uefi-boot-Hyp.JPG

pvs-uefi-boot-Xen.JPG

Link to comment

1 answer to this question

Recommended Posts

  • 0

Hi Herwin,

 

Having the exact same issue. After each reboot an entry is added that will slow down boot bit by bit after each daily reboot. Same things show as in your setup. We're running VMware with PVS and the only way for us to clear all entries is remove them manually from EFI setup on VMware or by removing the .nvram file from the VMware datastore. Funnily enough, this does not occur when booting the vdisk in read/write mode. No extra entries are created on boot. Did you ever manage to find a solution?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...