Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Workspace on Linux (tar.gz installation) not integrating plugin

Alexandros Karypidis




I am trying to install the latest Citrix Workspace (not receiver) in Solus Linux which does not support deb/rpm so I used the tar.gz installer as follows:


  1. Downloaded and extracted linuxx64-
  2. Ran as root: "sudo ./setupwfc" and selected the options below:
  3. Select a setup option:
     1. Install Citrix Workspace app for Linux 19.12.0
     2. Remove Citrix Workspace app for Linux 19.12.0
     3. Quit Citrix Workspace app for Linux 19.12.0 setup
    Enter option number 1-3 [1]: 1
    Please enter the directory in which Citrix Workspace app for Linux is to be installed.
    [default /opt/Citrix/ICAClient] 
    or type "quit" to abandon the installation: 
    You have chosen to install Citrix Workspace app for Linux 19.12.0 in /opt/Citrix/ICAClient.
    Proceed with installation? [default n]: y
    Installation proceeding...
    Checking available disk space ...
    	Disk space available 68907888 K 
    	Disk space required 257239 K
    Continuing ...
    Creating directory /opt/Citrix/ICAClient
    Core package...
    Setting file permissions...
    Integrating with browsers...
    Browsers found.
    Integration complete.
    Do you want GStreamer to use the plugin from this client? [default y]: y
    Do you want to install USB support? [default n]: n
    USB support not installed.


However, when I log into my company web site using Firefox, I ALWAYS get the HTML viewer instead of the native one. Can someone explain how this installer integrates with Firefox and how I can enable it manually?



Link to comment

6 answers to this question

Recommended Posts

  • 0

Just to add that I tried using Chrome and there I get a prompt to download the ICA file but when I try to open the downloaded file I get a certificate error:


SSL error: Contact your help desk with the following information: You have not chosen to trust "Entrust Root Certification Authority - G2", the issuer of the server's security certificate (SSL error 61)


Link to comment
  • 0

To further ad to this: I got it working in Chromium, but still no joy in Firefox!


To fix it in Chromium I did the following:


# cd /opt/Citrix/ICAClient/keystore/
# mv cacerts cacerts.original
# ln -s /etc/ssl/certs cacerts

Basically, I replaced the certificates that ship with the Workspace client with those that ship with the OS. So now I can open the ICA file when it gets downloaded by clicking on it (I will look into this; would like Chromium to do this automatically) and it works!


Still no joy on Firefox though... If I could get some details on where the plugin is placed I might be able to help create a proper package for this...


Where in /opt/Citirx/ICAClient is the mozilla plugin located? I would like to make sure it is linked to by the plugins folder?

Link to comment
  • 0

I have identified something strange which may be the cause of this: file "/opt/Citrix/ICAClient/npica.so" is missing. The installer does not create it. This is likely why this does not work in Firefox.


So to recap, my problem is that Citrix Workspace App will not run in Firefox because the installer does not put the plugin in the install location.

  • Running 64-bit Linux version 5.5.7
  • Running 64-bit Firefox version 74
  • Running 64-bit Chromium version 80.0.3987.132
  • Installed 64--bit Citrix Worspace
    • Enabled system certificates from OS (ln -s /etc/ssl/cer/opt/Citrix/ICAClient/cacerts)
  • Works: connecting with ICA client from Chromium (downloads ICA file and I open it with wfica)
  • PROBLEM: Firefox does not work because /opt/Citrix/ICAClient/npica.so is missing:
root@pc ~ # ls -l /usr/lib64/mozilla/plugins/npica.so
lrwxrwxrwx 1 root root 30 Mar 22 23:03 /usr/lib64/mozilla/plugins/npica.so -> /opt/Citrix/ICAClient/npica.so
root@pc ~ # ls -l /opt/Citrix/ICAClient/npica.so
ls: cannot access '/opt/Citrix/ICAClient/npica.so': No such file or directory

Can you please explain why the installer links to a non-existent plugin?

Link to comment
  • 0

Have the same issue, I looked through some earlier versions of the citrix workspace linux installer and it seems like the last one that included this npica.so file was linuxx64- However, after trying out that file and putting that manually in the ica installation path it seems firefox still does not want to recognize it. Would also like to get some more information regarding this :)


BR, David

Link to comment
  • 0

@Alexandros Karypidis thank you for the above, that resolved that issue but now I am encountering Cannot find an ICA file or appserv.ini entry

I tried deleting .ICAClient from home per instructions from a Ubuntu user having same error, no dice. 

I also copied the "launch.ica" from tmp folder to the opt/Citrix directory, ran from Terminal still more errors. 


I am running Solus Fortitude 4.1

Link to comment
  • 0

@Spencer Crawford Sorry, I was only logging into this while investigating the issue.


I am also on Solus 4.1 so it must be possible to fix it. I never got this error you mention. Are you using Chromium or Firefox? I only ever got this to work on Chromium.


If you run /opt/Citrix/ICAClient/wfica.sh from command line you will get this exact error. This is because you must pass a ".ica" file as a parameter. For example "/opt/Citrix/ICAClient/wfica.sh <some_hex_hash>.ica


When I log into work, Chromium downloads a  filename with extension ".ica". I click on it and it and choose to open with /opt/Citrix/ICAClient/wfica (you can get Chromium to remember this) and then it works. The file is deleted automatically by /opt/Citrix/ICAClient/wfica when it is opened, so I suggest you configure Chromium to save the file (the default) and open it manually to confirm it works. Once you have it working, you can make that automatic.


Hope this helps.


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...