Jump to content
Welcome to our new Citrix community!
  • 0

[Solved] .ica files do not open - "Citrix Workspace" loading window disappears after seconds in Fedora


Anna Schneider

Question

Hi guys,

due to the Corona pandemic I am now quarantined and have to work from home.

To this end I installed Citrix Workspace. It was no problem to log into my employer's account and access my desktop in Firefox.

HOWEVER whenever I click on an icon, all that happens is that a little "Citrix Workspace - Connecting to blabla.com" window pops up for a few seconds. Instead of a progress bar there is only an unspecified progress indicator (one of these chaser light like things) and then the window disappears. That's all.

To make sure it is not a Linux problem before talking to our support (they only do Windows:51_scream:) I installed the Citrix Workspace App in a Windows virtual machine, basically following the same steps as in Fedora. To my dismay there was no problem at all - everything worked flawlessly.

Do you have an idea - even a faint one - what I can do to make it work in Fedora?

Best, Anna

Link to comment

5 answers to this question

Recommended Posts

  • 0

Hi

 

Assuming you use Fedora 31 and Workspace app 19.12.

 

Open a terminal window and copy-paste the following line by line:

# workspace app needs a previous release of openssl
sudo dnf install compat-openssl10
# modify the workspace app launch shortcut to use library from compat-openssl10
sudo sed -i 's/^Exec=/Exec=env LD_PRELOAD=\/lib64\/libcrypto.so.1.0.2o /g' /usr/share/applications/wfica.desktop

 

If you get a certificate error starting the app/desktop, do:

cd /opt/Citrix/ICAClient/keystore/cacerts/
# extract certificates from tls-ca-bundle.pem
sudo awk 'BEGIN {c=0;} /BEGIN CERT/{c++} { print > "cert." c ".pem"}' < /etc/pki/ca-trust/extracted/pem/tls-ca-bundle.pem

 

Link to comment
  • 0
52 minutes ago, Stian Viskjer said:

 

Thank you, Stian!

 

There is indeed a certificate error now - which persists even after I used the two command lines you posted.

 

It reads "SSL error : Contact your help desk with the following information: You have not chosen to trust "Thawte RSA CA 2018", the issuer of the server's security certificate (SSL error 61)."

 

The certificate mentioned was sent to me by our (Windows only) support (after I had asked them about the problem described above) with the suggestion to "just click on it and see what happens".

 

Any idea what to do next?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...