Jump to content
Welcome to our new Citrix community!
  • 0

Creation of Machine Catalogue on Azure using VHD in Azure blob storage fails with Error Id: XDDS:B8EA803C


Tatyana Saar

Question

Good Day,

 

We have a Citrix Virtual Apps And Desktops 7.1912 installation with Windows Server 2016 VDAs that are hosted on a Citrix Hypervisor 8.1 (build 8.1.7256) 64bit host.  We have exported our Master image to OVA, exported the VHD and converted it to Fixed size.  We then uploaded it to Azure blob storage using Azure Storage explorer.  However when we attempt to create a Machine Catalogue through Studio up into Azure we get the following error

 

Error Id: XDDS:B8EA803C

Exception:
    DesktopStudio_ErrorId : ProvisioningTaskError
    ErrorCategory : NotSpecified
    ErrorID : ImagePreparationFinalizationFailedCompletely
    TaskErrorInformation : No Image Preparation results found. There may be no suitable VDA installed, or some other serious failure in the Master VM. Image preparation failed.
    InternalErrorMessage : No Image Preparation results found. There may be no suitable VDA installed, or some other serious failure in the Master VM. Image preparation failed.
    DesktopStudio_PowerShellHistory : Create Machine Catalog 'Xenapp - Azure'
    12/03/2020 15:30:39
    
   **Pruned Powershell commands**
    
    Error Source : Citrix Studio
    
    StackTrace: Citrix.Orchestration.Base.LogicModels.Exceptions.ProvisioningTaskException Preparation of the Master VM Image failed. Make sure the selected image has a supported OS (for example, Windows 7) and the correct version of the VDA (7.0 or later) installed.
       at Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeTask.ThrowOnTerminatingError(SdkProvisioningSchemeAction sdkProvisioningSchemeAction)
       at Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeTask.WaitForProvisioningSchemeActionCompletion(Guid taskId, Action`1 actionResultsObtained)
       at Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeCreationTask.StartProvisioningAction()
       at Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeCreationTask.RunTask()
       at Citrix.Orchestration.Base.PowerShellSdk.BackgroundTaskService.BackgroundTask.Task.Run()
    

 

The Azure service account was created in Studio for this purpose and does appear to be working up in Azure.  As I can see some resources attempting to be created but it fails and then deletes the resources.

 

The only possible issue we could have is that the host has AMD EPYC 7501 CPUs, however even when selected an AMD machine in Azure we get the same error

 

Has anyone else seen this error and have a suggestion?

 

Cheers

Link to comment

2 answers to this question

Recommended Posts

  • 0

i can't see that ending well.....there are quite a few steps you need to do when moving a VHD into Azure from an existing image, the only nice and clean way (in my experience) is to do it in Hyper V (yes it can be done with others, but its going to be nice and clean in Hyper-V)

 

Any reason you can't build natively in Azure? If you can't, then i would suggest heavily that you stand up a small Hype-V environment and build your images there prior to shipping to Azure

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...