Jump to content
Welcome to our new Citrix community!
  • 1

How to prevent Workspace App to launch in foreground?


Baumgartner AG

Question

Hi Folks

 

I am looking for a solution on how to stop Citrix WOrkspace App from launching in foreground for no reason. Affected Machine is a HP thin client t630. Computer has joined domain, but the logged in user is a local non-domain user.

 

User is working in "KIOSK" mode, which means after autologin on the client, he can only see his desktop on the screen. Launching the desktop works like a charm. But everytime I launch the desktop, this damn workspace app window lauches in foreground and stays there until I close it manually.

 

image.thumb.png.34f772c5bbbfb7c42de9ae64b0a59cd6.png

 

Thanks and best regards

 

Cedy

Link to comment

7 answers to this question

Recommended Posts

  • 0

Update: Managed to disable automatic storefront mapping via GPO. But now, Workspace app autostarts at every logon with the window: Enter storefrond adress.

 

Workspace app is not in All Users Autostart, not in users autostart, not inside the RUN key in registry, and autostart ist also disabled in Task manager... I really don't know how to prevent it from launching after logon.

 

I also tried to enable the checkbox "don't show this window on startup", but that also doesn't help.

 

Link to comment
  • 0

I am actually seeing the same thing in a Server VDA running Windows Server 2016. Workspace App is 1912 LTSR and when a user with a fresh profile logs into the published desktop, Workspace App opens in the foreground with a spinning wheel as you've shown and stated. Stays until you close it manually and when you re-open it shows the apps that the user has access to (like Workspace App should do by default). Subsequent logins (using FSLogix to capture the user profile), Workspace App starts minimised as I would like it to do from the get go. What version of Workspace App are you running in your machines?

Link to comment
  • 0

OK - resolved it in my environment. As per the image below, I used Group Policy to "Disable" the "EnableFTU" policy. Fresh profile logins and subsequent logins, Workspace App starts in the background, not in the foreground. SSO is still happening as expected.

 

[EDIT] don't enable "Pre-Launch" on any Delivery Groups either, otherwise the issue returns.

 

EnableFTU.thumb.jpg.d7d3ffb5d5540db4ebf6210e27062c87.jpg

Edited by mgailer
Pre-Launch Finding
Link to comment
  • 0
On 4/17/2020 at 2:30 AM, Matthew Gailer1709152490 said:

OK - resolved it in my environment. As per the image below, I used Group Policy to "Disable" the "EnableFTU" policy. Fresh profile logins and subsequent logins, Workspace App starts in the background, not in the foreground. SSO is still happening as expected.

 

[EDIT] don't enable "Pre-Launch" on any Delivery Groups either, otherwise the issue returns.

 

EnableFTU.thumb.jpg.d7d3ffb5d5540db4ebf6210e27062c87.jpg

OK great, I will give this a try when I've got time. 

 

Thanks

Link to comment
  • 0

i Have to revert. .\WorkSpaceApp.exe /ALLOWADDSTORE=N didnt work. In the Past it works for "CitrixReceiver.exe /ALLOWADDSTORE=N".

I have used the latest ADMX Files for Receiver&Workspaceapp and CitrxBase, tried the GPO and rename the WorkspaceApp.exe to WorkSpaceAppWeb.exe. with the /ALLOWADDSTORE=N. Cheking the registry Values in Dazzle and Citrix on HCU and HKLM, didnt use pre-launch or sso,but it still pop up... 

Edited by rknigs197
.
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...