Jump to content
Welcome to our new Citrix community!
  • 0

NFS path not accepted for "Rolling Pool Upgrade"


Peter VARGA1709157052

Question

I want to upgrade my XenServer 7.6 to 8.1 through the "Rolling Pool Upgrade" option in XenCenter.

When I select "NFS" and set the path 192.168.229.249:/ISO I get in the pre-check the attached error.

 

These conditions apply:

  1. The NFS path is accessible from XenCenter and XenServer.
  2. I am trying it on XenCenter 8.1 (build 8.1.2.7319) 64-bit.
  3. There is no VM running on the XenServer. All VM are down - not in the suspended mode.
  4. The NFS share is on another linux server.

 

I tried the two below methods. No success at all even the content of the .iso file is listed in the NFS share:

  1. The CitrixHypervisor-8.1.0-install-cd.iso file has been unpacked according to this article https://docs.citrix.com/en-us/citrix-hypervisor/install/upgrade.html
  2. The CitrixHypervisor-8.1.0-install-cd.iso file has been mounted to the NFS share.

 

What am I doing wrong, what do I have to enter in the NFS field?

 

Here the content from 192.168.229.249:/ISO:

[/share/ISO] # ll
dr-xr-xr-x    7 admin    administ      2.0k Dec  4 16:48 ./
drwxrwxrwx   40 admin    administ      4.0k Mar 17 10:49 ../
-r--r--r--    1 admin    administ       226 Dec  4 16:48 .treeinfo
dr-xr-xr-x    3 admin    administ      2.0k Dec  4 16:38 EFI/
-r--r--r--    1 admin    administ     29.0k Dec  4 16:38 EULA
-r--r--r--    1 admin    administ    425.6k Dec  4 16:38 LICENSES
dr-xr-xr-x    2 admin    administ     86.0k Dec  4 16:48 Packages/
-r--r--r--    1 admin    administ      1.0k Dec  4 16:37 RPM-GPG-KEY-CH-8
-r--r--r--    1 admin    administ      1.0k Dec  4 16:37 RPM-GPG-KEY-CH-8-LCM
-r--r--r--    1 admin    administ       947 Dec  4 16:37 RPM-GPG-KEY-Platform-V1
dr-xr-xr-x    4 admin    administ      2.0k Dec  4 16:38 boot/
dr-xr-xr-x    2 admin    administ      2.0k Dec  4 16:48 client_install/
-r--r--r--    1 admin    administ    101.0M Dec  4 16:38 install.img
dr-xr-xr-x    2 admin    administ      4.0k Dec  4 16:48 repodata/

 

2020-03-17_12-15-01.jpg

Link to comment

6 answers to this question

Recommended Posts

  • 1

Do showmount -e 192.168.229.249 to see if you can see the mount.

It may be presented differently that just iso.  Also, I think just NFS v3

is supported. And to top all of that off sometimes NFS just doesn't 

work and you have to try a different NFS server or upgrade with 

CIFS, FTP, or media. The rolling pool upgrade use to work better.

 

--Alan--

 

  • Like 2
Link to comment
  • 0
6 hours ago, Alan Lantz said:

...

Also, I think just NFS v3 is supported.

...

 

--Alan--

 

 

Thank you so much Alan!

 

The NFS share is on a QNAP where V3 was already running. So I changed it to V4 and then it worked perfectly. I could upgrade through XenCenter the XenServer 7.6 to HyperVisor 8.1.

 

Honestly, it's a shame this is not mentioned in the documentation. It is just a notice with few words which saves hours. Citrix, very disappointing!

Link to comment
  • 0
7 hours ago, Tobias Kreidl said:

Unless you force v4, I am very surprised thta a fallback to v3 did not take place.. I'd check if the allowed connection protocol on the Citrix Hypervisor server might have been set to accept only v4.

 

It was a XS 7.6 test installation from the scratch in order to test the upgrade process where I haven't set anything apart from the questions while the installation.

Where can I check it so I can reply here for other who may have the same issue.

Link to comment
  • 0

Hello

 

I had the same issue trying to upgrade from Version 7.2 to 8.2, but however, the solution that worked on my case is not version specific.

I have an NFS Share, and I am using a Mac computer, but I have also tried with a Linux VM that I use from time to time, and somehow, unpacking the ISO on my mac or linux and copying with SCP or RSYNC to the server did not mad the job properly. I think there is something related to encoding or transfer mode(text/ASCII).

 

However, I have decide to give a try with Windows + Winscp. I have mounted the ISO(not unpacked) and copied the content directly from the mounted ISO to the NFS. Yep, that worked. ?

 

I suggest that the users which end up reading my post and no other solutions worked for them so far, is to pay attention how you "unpack/mount" the ISO and how you transfer the content to the NFS Share. Make sure there is nothing wrong with Encoding or Transfer Mode.

In SCP the transfer mode is set as part of [[transfer_settings|transfer settings]].

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...