Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Workspace App: Connection Error, “Engine was not loaded; You have not chosen to trust “USERTrust RSA Certification Authority”, the issuer of the server’s security certificate. Error Number: 183.


Jill Achanzar

Question

On an iPad, iOS 9.3.6 cannot be upgraded anymore, is getting a Connection Error,  “Engine was not loaded; You have not chosen to trust “USERTrust RSA Certification Authority”, the issuer of the server’s security certificate.  Error Number: 183.

We have been seeing more and more Personal Mac issues for about 3 weeks now where they are getting the RSA certificate error while running El Capitan.  I've tried upgrading to Sierra, High Sierra, Mojave, and Catalina.  If they can upgrade the OS to Catalina and run the current version of the Citrix Workspace App, it worked once, but not for all Macs.
Of course the customer's do not want to hear that their Mac is outdated and may need to buy a new one just to use Citrix.
Has anyone else started to encounter these errors recently too?

Link to comment

1 answer to this question

Recommended Posts

  • 0

Hi,

 

That certificate is not present in iOS 9:

https://support.apple.com/en-gb/HT205205

But is is in iOS 10 and above.

You could try following this guide to manually install the certificate:

https://support.citrix.com/article/CTX228877

 

On macOS, it is in there since Sierra.

But just the same, you could try installing it manually:

https://support.securly.com/hc/en-us/articles/206058318-How-to-install-the-Securly-SSL-certificate-on-Mac-OSX-

 

Best,

 

Koenraad

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...