Jump to content
Welcome to our new Citrix community!
  • 0

Using PVS to Pass Printers Through - Navision


Mark Sammut

Question

Hey all, 

 

Really strange one here and we've been banging out head against the wall for the past few weeks. After multiple search engine queries and multiple 'fixes' we cannot resolve the issue we're having so to this forum I come looking for an answer hopefully. 

 

Background: 

  • We are migrating Navision from our old Windows 2008 environment to PVS - Citrix Studio 7.15
  • Navision is installed and people are working on it. 
  • Users are able to connect and their printers are passing through (Can see them in Print Management) 
  • When the user tries to print they are presented by an error of ''You cannot print to 'Insert Printer Name here' (From 'PC Name Here') in session 35 (for example) winspool NE00:' - This translates in Windows Event Viewer  to 'An error occurred while configuring print queue 'Printer name here (from PC Name Here) in session 12'. Printer driver 'Microsoft XPS Document Writer v4' may not be used in conjunction with a non-inbox port monitor.' - Event ID 242

 

We've tried the following fixes, but alas with no result: 

  • https://support.citrix.com/article/CTX239344 - Error "An error occurred while configuring print queue, printer driver may not be used in conjunction with a non-inbox port monitor"
  • https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/policies/reference/configure-com-ports-and-lpt-redirection-using-registry.html - Configure COM Port and LPT Port Redirection settings using the registry
  • Removing and Reinstalling the printers

 

  • Applying these Policies in Citrix Studio: 
  • Auto Connect Client COM Ports (Enabled)
  • Auto Connect Client LPT Ports (Enabled)
  • Client COM Port Redirection (Allowed)
  • Client LPT Port Redirection (Allowed)

 

The Servers that Navision is being ran on are Windows 2016 boxes (2 of them). 

 

It seems that the printers aren't being passed through correctly. However, if I publish 'Notepad' from one of the PVS machines I can print to a local printer with no issues. So it's strange.... 

 

TLDR: 

Trying to Print from Navision, got errors

Hitting our heads against the wall

Tried multiple fixes - No luck 

Help Please. 

 

Thanks in advance for any suggestions! Likewise, if anyone can help us fix this you'd make a Windows Admin team VERY happy. 

 

Thanks!

 

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...