Jump to content
Welcome to our new Citrix community!

Single Sign-On to Virtual Apps and Desktop (Gateway Server) and SAML WebApplication (Content Switch Server)


Recommended Posts

Hi there,

 

i have a content switch virtual Server which switches the user to different Web Application with SAML authentication enabled. The SAML mechanism redirects to my authentication virtual server "auth.domain.com". After succesfull authentication, the user gets redirected to his WebApplication.

 

And i have a Citrix gateway virtual server with domain "ctx.domain.com", which uses the same AAA-vServer.

I don't want the user to authenticate again, when switching between the sites. How can i achieve this? 

Link to comment
Share on other sites

Yeah I know this procedure for SAML authentication (for example with AzureAD as IdP) . But on my Citrix Gateway vServer, i don't use a SAML. I just do the LDAPS/OTP authentication with the same AAA-vServer, which has a SAML Profile for an unrelated WebApplication (SAP FIORI as SP, ADC as IdP).

 

Link to comment
Share on other sites

Sorry I misunderstood your SAML configuration.

 

Is the 2nd login prompt coming from Storefront? As you're already authenticated with the AAA server I would assume it passes you through to storefront in which case you would just need a traffic policy to do single sign on using the credentials you've already entered. 

 

 

Link to comment
Share on other sites

It's the same AAA vServer. pass through to storefront is working fine.

I think the problem comes with the different login domain names. Even though i'm using the same AAA vServer. Virtual Apps Login site is "ctx.domain.com" and WebApps is "auth.domain.com".

Maybe i can redirect login to virtual Apps to "auth.domain.com"?? 

Link to comment
Share on other sites

1 hour ago, Andre Schreiber said:

It's the same AAA vServer. pass through to storefront is working fine.

I think the problem comes with the different login domain names. Even though i'm using the same AAA vServer. Virtual Apps Login site is "ctx.domain.com" and WebApps is "auth.domain.com".

Maybe i can redirect login to virtual Apps to "auth.domain.com"?? 

 

Hi Andre,

 

check your AAA authentication profile. In "Authentication Host" there is auth.domain.com - correct? Check that "Authentication Domain" is set to empty with the "Authentication Level" of 0. Edit your Gateway vServer and enable "Login once". Than try again, SSO between your AAA "auth.domain.com" and your GW "ctx.domain.com" should work now. Watch out when testing that you are using a private browser session because of older cookies / caches. 

 

Regards

Julian

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...