Jump to content
Welcome to our new Citrix community!

Which firmware to download for Netscaler update


Recommended Posts

I need to upgrade netscaler firmware to address CVE-2019-19781.
Citrix have following 2 links for firmware download:-
https://www.citrix.com/downloads/citrix-adc/
https://www.citrix.com/downloads/citrix-gateway/
Which link should I use to download the package?

These are virtual appliance on ESXi.

1. One Netscaler current firmware is NS10.5: Build 55.8007.e.nc.
It has following features enabled:-        
 Feature                        Acronym              Status
-------                        -------              ------
 Load Balancing                 LB                   ON
 Content Switching              CS                   ON
 SSL Offloading                 SSL                  ON
 Rewrite                        REWRITE              ON
 Responder                      RESPONDER            ON
 AppFlow                        AppFlow              ON
Shoudl I download the "Netscaler Gateway 10.5.e" frimware for it from the https://www.citrix.com/downloads/citrix-gateway/ URL?

If I choose this one then the latest one is from Sep 25, 2017 which won't cover this CVE.

 

If I choose the "Netscaler Gateway 10.5" frimware then the latest is Jan 24, 2020 which shoudl cover this CVE.

 

If I choose the "Netscaler ADC release 10.5" frimware/virtual appliance for it from the https://www.citrix.com/downloads/citrix-adc/ URL then the latest is from Jan 24, 2020 which shoudl cover this CVE.
Which one should I choose?


2. Another netscaler has firmware - NS12.1: Build 50.31.nc
It has following features enabled:-
 Feature                        Acronym              Status
-------                        -------              ------
Load Balancing                 LB                   ON
Content Switching              CS                   ON
SSL Offloading                 SSL                  ON
SSL VPN                        SSLVPN               ON
Responder                      RESPONDER            ON
AppFlow                        AppFlow              ON
CallHome                       CH                   ON

 Mode                           Acronym              Status
-------                        -------              ------
Fast Ramp                      FR                   ON
Edge configuration             Edge                 ON
Use Subnet IP                  USNIP                ON
Layer 3 mode (ip forwarding)   L3                   ON
Path MTU Discovery             PMTUD                ON
Shoudl I download the "Netscaler Gateway 12.1" frimware for it from the https://www.citrix.com/downloads/citrix-gateway/ URL?

OR 

"Netscaler ADC release 12.1" frimware/Virtual Appliance from https://www.citrix.com/downloads/citrix-adc/ URL

Link to comment
Share on other sites

36 minutes ago, Manoj Rana said:

Hi,

 

You need Citrix ADC firmware if you have Load Balancing, Content Switching ,SSL Offloading, Rewrite etc.
  

https://www.citrix.com/downloads/citrix-adc/

 

Thanks 

Manoj

 

Thanks Manoj. But the for NS10.5 they don't have the ".e" version for the ADC in the downloads page. One of the netscalers has the NS10.5: Build 55.8007.e.nc version. Shouldn't I be using the ".e" version for this?

And if I need to download the ADC version then do I download the from the Virtual appliance section or the firmware section? :-

image.thumb.png.63cfa5f01616a7e6f31904538b1c11a0.png

Link to comment
Share on other sites

I don't think you can directly upgrade to 12.1

 

You may use the following path: 10.5 > 11.0 >12.0

CLI method of upgrade is recommended in this case

 

Refer to the following link for more info about the upgrade: 

https://docs.citrix.com/en-us/netscaler/12/upgrade-downgrade-netscaler-appliance/upgrade-standalone-appliance.html

https://support.citrix.com/article/CTX127455?recommended

https://support.citrix.com/article/CTX126793

 

 

https://discussions.citrix.com/topic/393050-netscaler-upgrade-path/

 

Thanks 

Manoj

 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...