Jump to content
Welcome to our new Citrix community!

http header "client-auth" is passed to the backend server when client certificate authentication is enabled


Recommended Posts

I followed the below article to configure client certificate authentication on my vserver.

 

https://docs.citrix.com/en-us/netscaler/12/ssl/config-client-auth.html#enable-client-certificate-based-authentication

 

 

set ssl vserver <vServerName> -clientAuth ENABLED -clientCert OPTIONAL

 

It is working fine but I see a "client-auth" header is passed to the backend server. I have already configured a ssl policy to pass the certificate information in another http header.

 

client-auth: Bad cert: UNABLE_TO_GET_ISSUER_CERT_LOCALLY 

 

I tried many options to disable this header but unable to do the same. Is there any way to disable this header?

 

In SSL profile I found there is a option "insertionEncoding" which says "Encoding method used to insert the subject or issuer's name in HTTP requests to servers". But there is no way to disable this header.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...