Jump to content
Welcome to our new Citrix community!
  • 0

XenApp 7.15 CU5 Upgrade - Unable to launch apps until server reboot


Kalpesh Mistry1709156584

Question

XenApp 7.15 CU5

VDA's on Windows 2008 R2

Delivery Controllers on Win 2016

Storefront on Win 2016

 

I've recently upgraded our XenApp 7.5 VDA's to 7.15 CU5. This was done by uninstalling 7.5 before installing 7.15.

The VDA's were then registered against a new 7.15 CU5 site.

 

Apps launch fine from this new site, but every 2 to 3 days any of the servers in the delivery group would fail to launch the application.

The receiver progress bar goes through the motions with no issue, but no app appears on the client screen.

 

Citrix studio and the app server show that a session has been started on the server with "Active" state.

Nothing obvious is seen on the VDA, DDC or Storefront event logs.

Its only after the VDA is rebooted that apps start to launch again successfully.

 

The Delivery group is only configured for apps and no desktops, however if i configure the DG with a desktop it opens up with a grey screen.

 

Legacy Graphics is disabled on the DG

With Legacy Graphics enabled the desktop seems to open ok. And when i launch applications these also open, but within a non-seamless window.

 

So it does seem to be some sort of graphics display issue.

I have tried setting the registry key Seamlessflags with 0x4 (as recommended by Citrix), but still no joy.

 

Has anyone come across this or have any suggestions?

 

Thanks

Kal

Link to comment

2 answers to this question

Recommended Posts

  • 0

Hi Silvio

 

Managed to find a solution to this,...

 

On my 7.5 VDAs I have the following registry items which are missing from the 7.15 VDA....

 

HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\AppInit_DLLs

Value : c:\progra~2\citrix\system32\mfaphook.dll

 

HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\LoadAppInit_DLLs

Value : 1

 

 

Once I added both of these the apps are launching without the need to reboot the server.

I did not implement the 7.5 Site, so its likely these were added manually.

 

Kal

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...