Jump to content
Welcome to our new Citrix community!
  • 0

Stale iSCSI entries


Paul Hutchins1709155747

Question

Hi,

Having problems removing stale entries from a host that I was previously using with iscsi storage connections elsewhere.  When attempting to join the pool I get an error that it still has shared storage attached.  There were no entries in iscsd.conf for this, after doing some investigation I found that it was still listing two send targets using iscsiadm -m discovery -o show and also this command showed node connections iscsiadm -m node -o show.  I followed this article and removed the send targets and node references which was successful:

 

https://support.citrix.com/article/CTX218555

 

The ls command in each directory verified they were no longer present.  I attempted to join the host to the pool again but with the same error as before.  I tried just restarting the iscsi service with systemctl stop iscsid.service then systemctl start iscsid.service and also restarting the toolstack, both of which did not make any difference.  In fact after restarting the toolstack I found that in the /var/lib/iscsi/send_targets directory the two IP's had returned again.  Yet there is no longer a /var/lib/iscsi/nodes directory.

 

There must be somewhere else the host is storing the send target IP's I am still seeing.  I have also made sure the SAN no longer has the iqn of the host in it's access group list as well (which I had actually done several days ago).

 

Thanks,

Paul.

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...