Jump to content
Welcome to our new Citrix community!
  • 0

Default Printer is not retained ELM 20.1.0.15 with Full User Layer


Richard DiFolco

Question

I currently have about 300 Virtual Desktops built with version 20.1.0.15 of the Citrix App Layering ELM.  The final product is being deployed as a final image for VmWare Horizon to create Instant Clones from the image.   Everything works great! User layer off loaded to a file server with 10G connections, SSD load balanced etc...

 

but, of all things users default printers are not retained upon log off and log in.   I came from a Unidesk 2.x environment where this was not an issue.  The only thing that sort of works is forcing the GPO to enable windows to manage your printers which keeps the "last used printer" as the default.  Again that is not ideal as some users have multiple printers and the last used printer is not always their preferred default.

 

If someone out there has run into this, or has some sort of work around/solution please let me know.  I am in User cal lin nightmare right now. My poor helpdesk techs :-(

 

Thanks,

Rich

Link to comment

8 answers to this question

Recommended Posts

  • 0

Unidesk 2 had the ability to provide persistent desktops where all user settings were retained.  Citrix App Layering 4.x is a non-persistent highly available model.  That means you need to use another technology to manage/save users settings.  You can use Citrix Profile Management to do that.  It will sync all your user settings or only part based on your requirements.  If your using VMware View they have a similar product called Dynamic Environment Manager.

 

See https://support.citrix.com/article/CTX222893 for more info on how to install CPM

 

 

Link to comment
  • 0

Rob,

 

Thanks for the response.  I was under the assumption that using Full User layers would make those changes for the user.  All other settings are saved and retained for the exception of the default printer. If another application is needed I will get moving on that, but why would printer settings be any different from default application settings which are retained/?

Link to comment
  • 0

Rich,

 

I did a quick test and it worked for me.

 

First i had a Citrix Policy defined to remap the default printer from my client so I had to disable that.

 

Then i logged on and set my default printer to just the Microsoft PDF driver.  Its important to note that since the user layer is an elastic layer any printer driver you want to use has to be installed in the published image.  Users cannot install a driver into their user layer.  You can use GPO's to install printers for users when they log on see https://docs.citrix.com/en-us/citrix-app-layering/4/layer/enable-user-layers.html

 

I logged out, logged on again got a new machine and my default printer was set,

 

You can check also in the registry here for the default printer setting

 

image.thumb.png.31dc0a086f7098b60b55423097776c9b.png

 

Could it be that the printer drivers are not included in the image and also not installed for each user?

 

Link to comment
  • 0

Rob,

 

Thank you for the test and details above.  I wonder if it is related to the printer driver.  I do not have the driver bundled into the image.  It is pulled down when someone selects a printer from the print server.  

 

While you were testing I ran a few more and noticed what looked like printers being reinstalled after logging in. (Printers installed remained but the progress bar below showed what looked like a driver install/update)

 

I am going to add a printer driver layer and republish and test again.  I am also going to disable the printer redirection from the local client, for now.  I know that always took priority in the past with default printers, though the default that is selected is not that of a local printer.  I am going to guess the drivers are the issue.

Link to comment
  • 0

Hi Rich,

 

We also had this issue since at least 1908.  In order to fix it, we had to add our Platform Layer to the domain.  This step is mentioned in the relevant documentation page (https://docs.citrix.com/en-us/citrix-app-layering/4/layer/create-platform-layer.html), but it was omitted in our earlier iterations.  This didn't fix the issue retroactively for user layers created before this image, but it seems to have fixed the issue for any user layers created after.  I know that's not an ideal fix, but I thought I would mention it all the same, as I spent a lot of time working on this as well.

 

Cheers,

 

Jordan

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...