Jump to content
Welcome to our new Citrix community!
  • 0

Automatic reboot of MCS devices after updating vCenter certificate


Luke De Fazio

Question

We had our vCenter certificate expire and this resulted in the daily scheduled reboot failing, nothing strange there.

 

What was strange is the moment we fixed the vCenter certificate issue and Studio could resolve the Hosting connecting, every one of our devices in the Machine Catalog that was provisioning with MCS completed a shutdown and startup cycle.

 

Naturally this caught us off guard because we didn't;t expect the reboot cycle to occur once the Cert was fixed.

 

Has anyone experienced this behaviour before?

 

Was the reboot a  result of scheduled restarts failing and effectively queuing up until communication to vCenter was restored?

 

Once the reboots were completed the devices remained online and have not shown any abnormal behaviour since then.

 

thanks.

Link to comment

2 answers to this question

Recommended Posts

  • 1
On 2/19/2020 at 12:06 PM, Luke De Fazio said:

We had our vCenter certificate expire and this resulted in the daily scheduled reboot failing, nothing strange there.

 

What was strange is the moment we fixed the vCenter certificate issue and Studio could resolve the Hosting connecting, every one of our devices in the Machine Catalog that was provisioning with MCS completed a shutdown and startup cycle.

 

Naturally this caught us off guard because we didn't;t expect the reboot cycle to occur once the Cert was fixed.

 

Has anyone experienced this behaviour before?

 

Was the reboot a  result of scheduled restarts failing and effectively queuing up until communication to vCenter was restored?

 

Once the reboots were completed the devices remained online and have not shown any abnormal behaviour since then.

 

thanks.

Hi,

 

Was the reboot a  result of scheduled restarts failing and effectively queuing up until communication to vCenter was restored? - Yes

 

You can look with the command :  Get-BrokerRebootScheduleV2 -name "YOUR NAME" . 

 

You must have the variable  : Active : True instead of False. When you change the certificate, Citrix reboot all servers and the variable Active change to False.

 

However, you don't change this value with powershell. The solution is disable the reboot with GUI or CLI 

  • Set-BrokerRebootScheduleV2 -name "YOUR NAME" -Enabled $false

and reactivate after the change 

  • Set-BrokerRebootScheduleV2 -name "YOUR NAME" -Enabled $true

 

  • Like 2
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...