Jump to content
Welcome to our new Citrix community!
  • 0

VDI blank when launching Windows 10 Desktop from receiver/workspace app from one branch location


Stuart Donnelson

Question

I've got a really odd issue guys and could use some assistance.  I have two datacenters with Citrix resources in them.  All our XenApp workloads and infrastructure components for this 7.15 CU3 site are in Datacenter 1.  All of our XenDesktop workloads are in Datacenter 2.  One of our remote facilities is having connection issues to XenDesktop in Datacenter 2 but can launch shared-hosted desktops in Datacenter 1 just fine.  The VDI issues appear to only happen when using the workspace/receiver app and do not occur when going to the storefront web page.  This remote facility is on the internal network and connections are not routed through the Netscalers.  Here is what I know so far:

 

-Windows 10 VDI is blank/black/green when connecting to Datacenter 2 VDI resources using Workspace/Receiver in both windowed mode or full-screen

-Happens to multiple/all tested endpoint devices in the facility

-This facility is new and hasn't previously used our Citrix resources

-The same VDI works fine in receiver/workspace when on a different vlan/network on same endpoint devices (so when a user travels with that laptop to corporate or other branch locations)

-Using the storefront web page works fine connecting to datacenter 2 VDI 

-connecting to shared/hosted desktops in Datacenter 1 works fine from that network

 

-Backend 7.15 LTSR CU3 - tried multiple VDA versions on VDI (7.15 LTSR CU3, 1811, 1912)

-Tried versions of receiver/workspace (LTSR-7.15, latest workspace)

-No errors or warnings in event viewer on client or vda

 

I'm going to be doing some new testing here soon and will see if anything shows up in the client receiver/workspace logs but when we looked at this a while ago I don't remember seeing anything.  It's been one of those long-term headaches so we are going to go back to drawing board and step through everything again.  Any thoughts would be much appreciated!!!!

Link to comment

2 answers to this question

Recommended Posts

  • 0

Thanks for the insight Koenraad.  We were able to get the issue fixed.  Like you, we figured the problem had to be in the network somewhere so we started digging in a little deeper.  The MTU settings on the edge router were set below the standard 1500 bytes which was causing packets to become fragmented.  We didn't have access to EDT MTU discovery at the time since we were on 7.15 CU3.  Lowering the MTU settings on the VDA allowed us to compensate for this difference and fixed the issue.  

 

See here:

 

https://support.citrix.com/article/CTX123182

 

I just wanted to follow-up on this in case it helps anyone else out!

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...