Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Workspace for Linux (19.12.0.19) hotkey/shortcut key issues


Anthony Mincarelli

Question

I am working on building up a Raspberry Pi 4 thin client using Workspace for Linux 19.12, and are having trouble passing things like Ctrl+F12 into the remote session.  Ctrl+L works, but others are not.  We are using these shortcuts for our ERP software on our production lines, and it would be ideal if we could get them to work.

 

I've tried modifying the WFClient.ini to contain Hotkey char and shift information, but no luck.  The Pi is build on the latest version of Buster, using XFCE 4 to automatically launch the Workspace client.

Link to comment

2 answers to this question

Recommended Posts

  • 0
On 3/17/2020 at 2:40 AM, Patrik Pira said:

Try changing conf/module.ini, line 332, "F12=123" to "F12=(none)".

 

Did the trick for me when Shift+F12 did not work.

It looks like the XFCE 4 environment was stealing the shortcut keys.  I ultimately stripped that out of the image and have had success ever since.  Not sure why they buried the settings for that.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...