Jump to content
Welcome to our new Citrix community!

Citrix SSO VPN not working on MAC IS 10.15 Catalina users


Recommended Posts

Hi,

 

I am facing problem when I am using SSL VPN on MAC Catalina 10.15 OS using Citrix SSO App. also, tried with Citrix VPN gateway it is not working and there is no send receive bytes when connected to tunnel in VPN status bar. 

 

we had logged the case with Citrix last month for the same issue and it was resolved by Citrix SSO app not using Gateway plugin. The problem started when we upgraded it to Firmware 13.0-47.24.

 

I understand most of users who having MAC Catalina 10.15 facing same problem. Is there any way to fix this issue need your suggestion. 

 

Regards,

Ilyas Ahmed   

 

 

Link to comment
Share on other sites

  • 1 month later...
On 2/14/2020 at 1:07 AM, Ilyas Ahmed1709160958 said:

Hi,

 

I am facing problem when I am using SSL VPN on MAC Catalina 10.15 OS using Citrix SSO App. also, tried with Citrix VPN gateway it is not working and there is no send receive bytes when connected to tunnel in VPN status bar. 

 

we had logged the case with Citrix last month for the same issue and it was resolved by Citrix SSO app not using Gateway plugin. The problem started when we upgraded it to Firmware 13.0-47.24.

 

I understand most of users who having MAC Catalina 10.15 facing same problem. Is there any way to fix this issue need your suggestion. 

 

Regards,

Ilyas Ahmed   

 

 

Has anyone got back to you with a solution yet?? Im in the same boat.

 

Regards

YR

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
13 hours ago, Ilyas Ahmed1709160958 said:

Hi,

 

I resolved this issue by configuring manual DNS entry of my internal server in MAC.

 

The issue was remote DNS resolution it was going to public DNS if we query our internal server. 

 

I think It is bug in latest SSO application specially in Catalina OS. 

 

Regards,

Ilyas Ahmed  

 

Thanks but i tried this one already without any luck. I am actually using the Citrix Gateway VPN client only, for direct VPN access.

 

It looks like OSX 10.15.4 made major changes with the KEXT (Kernel Extensions), where lots of functions are deprecated. Apple has opted for more security by using Systems extensions instead. Citrix needs to rewrite the code for their SSLVPN plugins!!

 

https://developer.apple.com/support/kernel-extensions/

 

Regards,

Yuvy

Link to comment
Share on other sites

  • 2 weeks later...
On 4/10/2020 at 8:47 AM, Yuvy Ruhee said:

 

Thanks but i tried this one already without any luck. I am actually using the Citrix Gateway VPN client only, for direct VPN access.

 

It looks like OSX 10.15.4 made major changes with the KEXT (Kernel Extensions), where lots of functions are deprecated. Apple has opted for more security by using Systems extensions instead. Citrix needs to rewrite the code for their SSLVPN plugins!!

 

https://developer.apple.com/support/kernel-extensions/

 

Regards,

Yuvy

 

Hi Yuvy,

 

does this means that the issue is related directly to how citrix gateway plugin on Mac works. actually, we are currently doing a POC for our customer using netscaler version 13.0-47.24. out of sudden most of mac users having issue to access vpn resources even when they have connected successfully to vpn. i can see that the send/received bytes are 0. means there is not traffic being sent through the vpn tunnel. windows users are still working fine.

 

please advise.

thanks

Link to comment
Share on other sites

  • 4 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...